Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-21-2014, 12:27 PM
benjira's Avatar
Registered User
 
Join Date: Dec 2003
Location: Woodstock, GA.
Posts: 180
1989 300 SEL STARTING ISSUES

Hello folks. I am totally perplexed on my car at this point. It was stalling in a parking lot after warming up and not crank up. I would let it sit for a bit and it would start and get me home. It did this multiple times as well. I took it to the shop and it needed a tune up for sure. So i replaced plugs,wires,cap rotor,coil etc..... It seemed to run ok and then it started the same issue again. So I replaced the fuel pump,fuel filter, fuel pump relay. Still the same issue. It is back at my house and will hardly crank at all but it eventually will. I am scared to take it anywhere at this point. I also pulled the idle control valve and cleaned it as well. Is there something I have missed. It is really frustrating as this a great old car and I hate seeing her sit. Any help or things I can do to get her going would be greatly appreciated.


Thanks Much

BB

__________________

1972 SILVER 280SE
1989 SILVER 300 SEL
1984 DARK BLUE 300D EURO
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:15 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page