Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 04-18-2002, 03:21 PM
Posts: n/a
Angry 86 300e A/c

I recently had the AC charged and resealed and it blew cold air for 2 days. Now there's no power to the compressor clutch. Pressure is good, high and low switches are good. Climate control unit (push buttons) is new. I understand there is an AC compressor relay on this car. Where is that located?? Are there any other likely culprits?? Thanks!!
Reply With Quote
Old 04-18-2002, 04:11 PM
Senior Member
Join Date: Apr 1999
Location: Walnut,CA,USA
Posts: 554
A\C relay is locate behind battery right next to fuel pump relay the up-date number for your relay is 002-545-13-05 hope this help
MB STARS Master Guild Technician,17 years MB tech
14 years independent shop owner
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
300E misses with A/C on...Why??? mike690003 Tech Help 2 09-01-2003 04:45 PM
Replacing A/C Hose 1986 300E? zym57 Tech Help 2 03-18-2003 02:57 PM
MB or aftermarket A/C compressor? - 300E JFAZ Tech Help 2 01-17-2003 08:18 AM
a/c still working for no benefit on '86 300E can-do Tech Help 18 07-10-2002 11:31 PM
88 300E a/c and heat budman Tech Help 2 06-29-1999 09:56 PM

All times are GMT -4. The time now is 01:01 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page