Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-18-2002, 08:58 PM
Registered User
 
Join Date: Dec 1999
Location: Buffalo, New York USA
Posts: 69
terrible smell from AC System !!!!

W107 - 560SL - 1986 - all of a sudden I have an absolutely horrendous smell coming from my air vents. I have it taken down to the center console area directly beneath the radio, and I still can't finds anything. I'm assuming a mouse or something got in there, but I haven't the slightest idea of how or when. Anyone ever had this problem? Any ideas for de-smelling? it's taken the fun right out of driving with the top down for sure....

Can I get into that center air flow area? I opened up the blower area - nothing. I can see around the fresh air intakes - nothin. It seems heavier on the right side of the car than the left.
__________________
1986 560SL 145k
Reply With Quote
  #2  
Old 04-21-2002, 09:55 PM
Registered User
 
Join Date: Dec 1999
Location: Buffalo, New York USA
Posts: 69
My own follow up

Three days later and car still smells. It looks like there is an area beneath the blower where eith the heater or ac coil is - is this the only way in to see if there's an animal in there? I can't believe that I'm the first one to have this problem....
__________________
1986 560SL 145k
Reply With Quote
  #3  
Old 04-22-2002, 12:20 AM
Mike Murrell's Avatar
Registered User
 
Join Date: Feb 2000
Posts: 2,351
In the upper right hand corner, click on SEARCH

In the SELECT BY KEYWORD field, key in the word SMELL

In the SELECT FORUM select TECH HELP

Click on SELECT TITLE ONLY


I got 3-4 hits on A/C smell.
__________________
Mike Murrell
1991 300-SEL - Model 126
M103 - SOHC
"Fräulein"
Reply With Quote
  #4  
Old 04-27-2002, 01:39 PM
Black97S600
Guest
 
Posts: n/a
If it smells like band aid you got a leak some where
Reply With Quote
  #5  
Old 04-27-2002, 07:51 PM
Registered User
 
Join Date: Dec 1999
Location: Buffalo, New York USA
Posts: 69
Unhappy Still no luck!!!!

I wish I did. It is mildly better today, but still the car has a heavy odor. I've put two bars of fragrant soap in the well with the blower housing to spn some of that smell around, and I've let the car run for about 4 hours total with the heat on high to hasten the aging process of the decomposition. I took aprt both the right air handler stuff and the left air handler stuff behind the dash pod, and I still can't find anything.

With the valves all being vacumm controlled, the critter must have gotten in there when the car was off, then "fell" in a little deeper when the dampers opend up?

I was hoping to get some detailed diretions from someone who perhaps had been through this and had some luck, but nothing yet.
__________________
1986 560SL 145k
Reply With Quote
  #6  
Old 04-28-2002, 11:40 AM
conanh
Guest
 
Posts: n/a
It could be the fact that you AC drain is cloged witch causes milldue. Of corse it didnt happen untill you started using your AC did it.
Reply With Quote
  #7  
Old 04-29-2002, 01:07 AM
haasman's Avatar
Registered User
 
Join Date: Jun 2001
Location: San Francisco, CA
Posts: 3,097
I had a 240D that did this. It was a clogged or almost completely clogged drain. Someone told me to run a long tie-wrap or something somewhat flexible up the drain tube. I used one of those flexible "grabbers" with the little fingers at the end. I pulled out some REALLY weird stuff. I looked like a combo of wax and %#%(*(^$#. Oh BTW it REALLY stunk. The car slowly recovered its normal smell after that.
Reply With Quote
  #8  
Old 04-30-2002, 11:45 AM
mgnut
Guest
 
Posts: n/a
560 smells

Please let me know what you find, if you find anything, I have the same car , same problem, only mine smells like engine compartment fumes coming into the car, and its getting worse by the day ...
Reply With Quote
  #9  
Old 04-30-2002, 12:04 PM
Registered User
 
Join Date: Dec 1999
Location: Buffalo, New York USA
Posts: 69
Still Digging

I'll let you know - I work on it nearly everyday.
__________________
1986 560SL 145k
Reply With Quote
  #10  
Old 04-30-2002, 12:34 PM
PaulC
Guest
 
Posts: n/a
Unless you are certain that the smell is a dead animal, it is most likely mildew. I don't know any brand names, but there are solutions that you can purchase to flush out the air intake for the climate control system. Perhaps a dealership can advise.

Blocked drain hose? Start the engine and let the car idle for ten minutes with the A/C set on the coolest setting and verify the presence of clear water on the ground under the cowl area of the car. If none is present, check the interior carpeting for even a hint of moisture under the dashboard area. If the carpet is wet, the A/C condensation drain hose is either detached or blocked. If the carpet is dry and you spot water on the ground than the hose is either clear or only partially blocked.

Regarding my suggestion on the first paragraph: I have had luck ridding my A/C system of slight mildew odors by going to a self-service (wand-type) car wash and spraying soapy water into the cowl-mounted air intake for the climate control system. A temporary cure, but inexpensive.
Reply With Quote
  #11  
Old 04-30-2002, 01:32 PM
Fimum Fit
Guest
 
Posts: n/a
In our neighborhood --

we once had a family with a cat who developed the strange habit of jumping up on the warm hoods of cars and using the ventilation intakes as a litter box, and over on cartalk.com someone else in a distant state reported the same phenomenon. Could it be that it smells like cat urine???
Reply With Quote
  #12  
Old 04-30-2002, 01:37 PM
Registered User
 
Join Date: Dec 1999
Location: Buffalo, New York USA
Posts: 69
Cat Theory

I have cats and would know that smell from 1000 paces. Not the culprit, but thanks. Definately a heavy odor, dead animal'ish.
__________________
1986 560SL 145k
Reply With Quote
  #13  
Old 04-30-2002, 03:08 PM
J.HIDALGO's Avatar
Registered User
 
Join Date: Jul 1999
Location: Jax, FL
Posts: 1,785
I am not sure about your car but,

in my car the drainage for the air conditioner is under the car. One on each side of the transmission tunnel. If you don't see any condensation water under the vehivle, you are probably looking at clogged a/c drainage tubes. Just get under your car and use a long wire, run it through the drainage tubes VERY CAREFULLY! That should work!

OR

through the same drainage tubes, you can use a long plastic/rubber hose and introduce clorox or whatever odor/mildew eliminator you want to use. Read the label to avoid damamge to plastic, evaporator, etc...
__________________
J.H.
'86 300E
Reply With Quote
  #14  
Old 05-01-2002, 08:44 PM
Registered User
 
Join Date: Dec 1999
Location: Buffalo, New York USA
Posts: 69
That wasn't it

I had the blower housing off and directly poured some water over the coil - and it came out under the engine just fine. So I'm not blocked up. That leaves me with trying to see the other side (the underside) of the ac coil where the critter could have gotten in from the inside of the car. But I haven't seena a way to get to that area of the housing.
__________________
1986 560SL 145k
Reply With Quote
  #15  
Old 05-01-2002, 08:49 PM
mgnut
Guest
 
Posts: n/a
Thanks for your dillegnce Doug...has anyone ever seen the exhaust pipe that runs over the back of the engine from the drivers side to the passenger side next to the firewall develop holes or rust through and bleed exhaust from there?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
terrible smell from air vents! Doug41 SL Forum 8 10-12-2010 10:15 PM
For Sale:Excellent clear quality sounding stereo system ready to install. supermech2001 Car Audio and Multimedia 0 11-07-2004 01:01 PM
Arrrrgh!!! What a day. 123 AC system, Computers and Squirrels dmorrison Tech Help 3 04-28-2004 06:38 PM
Strange cooling system problem - exhaust gas entering system?? gsxr Tech Help 52 01-13-2002 12:10 PM
I smell gas in my trunk and car (90 300 SEL) mattsuzie Tech Help 4 03-26-2000 03:19 PM



All times are GMT -4. The time now is 05:19 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page