Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-06-2014, 02:04 AM
Registered User
 
Join Date: Jun 2013
Posts: 21
Smile Blower fan not work mercedes 300TE

Hallo guys I had 300TE 4matic 1993,the bower doesn't work at all no heat ,does this system had a relay

Reply With Quote
  #2  
Old 12-06-2014, 12:47 PM
Registered User
 
Join Date: Oct 2004
Location: Baton Rouge La
Posts: 2,631
Do a search. Either fuse on drivers inner fender or blower regulator. In a small amount of cases, u can turn the ignition key back a hair after starting the car
__________________
1989 300ce 129k
( facelifted front,updated tail lights, lowered suspension,bilstein sports, lorinser front spoiler, MOMO steering wheel, remus exhaust,stainless steel brake lines). (Gone)

1997 s320 154k (what a ride). Sold with 179k miles. Replaced with Hyundai Equus

1994 e320 Cabriolet 108k



1972 280se 4.5 153k Owned for 12 yrs, sorry I sold it


[/SIGPIC]
Reply With Quote
  #3  
Old 12-07-2014, 03:54 AM
Registered User
 
Join Date: Jun 2013
Posts: 21
Does on my model I had a blower strip fuse or a blower fuse on a fuse box

Last edited by ali112; 12-07-2014 at 04:14 AM.
Reply With Quote
  #4  
Old 12-07-2014, 04:45 AM
compress ignite's Avatar
Drone aspiring to Serfdom
 
Join Date: Feb 2004
Location: 32(degrees) North by 81(degrees) West
Posts: 5,554
HVAC Blower Motor "Strip Fuse"

Look for this on your Driver's side Shock tower.
It can have a Micro-fracture (Crack that you can't see,but can Measure with
a DMM's [Digital Multi Meter] continuity setting.
Also one of the screws might not be "Clean Bright and Tight".

That fuse was moved OUTSIDE the Fuse Box After a number of "Unauthorized Bar-B-Cues"

(Photo credit to GSXR)
Attached Thumbnails
Blower fan not work mercedes 300TE-screenhunter_108-dec.-07-04.46.jpg  
__________________
'84 300SD sold
124.128
Reply With Quote
  #5  
Old 12-07-2014, 08:07 AM
gatorblue92's Avatar
Save the manuals!
 
Join Date: Jan 2006
Location: Delaware
Posts: 3,388
My money is also on the fuse. Good luck finding one locally though unless you go to the dealer. Online they are about $1 or so.
__________________
1977 MB 240D 4 speed 145K - Nearly Perfect
1995 MB E420 197K - Weekend Toy
2018 Ford F150 5.slow 23K - My DD
2020 Subaru Ascent 10k - Wife's DD

1979 MB 280E 90K - Sold
1983 MB 240D 238K - Scrapped
1984 MB 300D 347K? - Sold
1984 MB 300TD Wagon - 188k - Sold
1987 MB 300E 5 speed 258K - Scrapped
1991 MB 300TE 5 speed 276K - Sold
1993 MB 400E 218K - Sold
1993 MB 400E 130K - Sold
1995 MB E320 Wagon 190k - Sold
Reply With Quote
  #6  
Old 12-07-2014, 01:07 PM
Registered User
 
Join Date: Jun 2013
Posts: 21
Thanks guys great info i make precise search on engine bay near the fuse box and ABS I did not find this type of strip fuse.I found a 25A blower fuse inside the fuses box.In the past this fuse was always burn when i turn the blower motor key speed,but now it doesn't burn and blower motor also not work.
Reply With Quote
  #7  
Old 12-08-2014, 01:40 AM
76 450sel
 
Join Date: Dec 2014
Posts: 1
HELP ME PLEASE! 1976 450 SEL BENZ HEAT PROBLEMS suck in the winter :)

I'm having the same problem in my 1976 450 SEL. Any help or links would be greatly appreciated. I feel heat coming out of the vents but the blower makes a screeching noise. I'm new to classic Benz's and do not know where to start. I can't even find a heater core or blower for it.

Thank you!
Reply With Quote
  #8  
Old 12-08-2014, 10:10 AM
JamesDean's Avatar
Electrical Engineer
 
Join Date: Apr 2005
Location: NE Ohio
Posts: 5,034
Quote:
Originally Posted by ali112 View Post
Thanks guys great info i make precise search on engine bay near the fuse box and ABS I did not find this type of strip fuse.I found a 25A blower fuse inside the fuses box.In the past this fuse was always burn when i turn the blower motor key speed,but now it doesn't burn and blower motor also not work.
The strip fuse should be located on the shock tower, just in front of the fuse box.

__________________
Cruise Control not working? Send me PM or email (jamesdean59@gmail.com). I might be able to help out.
Check here for compatibility, diagnostics, and availability!

(4/11/2020: Hi Everyone! I am still taking orders and replying to emails/PMs/etc, I appreciate your patience in these crazy times. Stay safe and healthy!)


82 300SD 145k
89 420SEL 210k
89 560SEL 118k
90 300SE 262k RIP 5/25/2010
90 560SEL 154k
91 300D 2.5 Turbo. 241k
93 190E 3.0 235k
93 300E 195k
Reply With Quote
  #9  
Old 12-08-2014, 10:14 AM
JamesDean's Avatar
Electrical Engineer
 
Join Date: Apr 2005
Location: NE Ohio
Posts: 5,034
Quote:
Originally Posted by Json210 View Post
I'm having the same problem in my 1976 450 SEL. Any help or links would be greatly appreciated. I feel heat coming out of the vents but the blower makes a screeching noise. I'm new to classic Benz's and do not know where to start. I can't even find a heater core or blower for it.

Thank you!
You should probably start your own thread about this topic.

A blower screeching noise is likely a bad bearing or an obstruction.

The blower motor assemblies on those cars are a bit different than the others. You should do a search on them and see what other members on here have to say. I've never worked on one so I can't directly comment.

Here is a link to the factory service manual for your car:
Model 107
__________________
Cruise Control not working? Send me PM or email (jamesdean59@gmail.com). I might be able to help out.
Check here for compatibility, diagnostics, and availability!

(4/11/2020: Hi Everyone! I am still taking orders and replying to emails/PMs/etc, I appreciate your patience in these crazy times. Stay safe and healthy!)


82 300SD 145k
89 420SEL 210k
89 560SEL 118k
90 300SE 262k RIP 5/25/2010
90 560SEL 154k
91 300D 2.5 Turbo. 241k
93 190E 3.0 235k
93 300E 195k
Reply With Quote
  #10  
Old 12-08-2014, 05:30 PM
Registered User
 
Join Date: Jun 2013
Posts: 21
Hallo thank you guys thanks James,The strip fuse on the picture that you upload i don't had it, i have only the 2 fuses on small black box near the shock tower,it puzzled me i searched very will ,Conceivable that does not exist in my car.i will make some search near the battery could it be on the passenger side.the vehicle its an European version not American.
Reply With Quote
  #11  
Old 12-08-2014, 06:05 PM
JamesDean's Avatar
Electrical Engineer
 
Join Date: Apr 2005
Location: NE Ohio
Posts: 5,034
Quote:
Originally Posted by ali112 View Post
Hallo thank you guys thanks James,The strip fuse on the picture that you upload i don't had it, i have only the 2 fuses on small black box near the shock tower,it puzzled me i searched very will ,Conceivable that does not exist in my car.i will make some search near the battery could it be on the passenger side.the vehicle its an European version not American.
Interesting.

If you look on your fuse box cover it should list out the fuse functions. Do you see any that mention the blower?

At one point in time Mercedes did use a 25A fuse inside the box for the blower.
__________________
Cruise Control not working? Send me PM or email (jamesdean59@gmail.com). I might be able to help out.
Check here for compatibility, diagnostics, and availability!

(4/11/2020: Hi Everyone! I am still taking orders and replying to emails/PMs/etc, I appreciate your patience in these crazy times. Stay safe and healthy!)


82 300SD 145k
89 420SEL 210k
89 560SEL 118k
90 300SE 262k RIP 5/25/2010
90 560SEL 154k
91 300D 2.5 Turbo. 241k
93 190E 3.0 235k
93 300E 195k
Reply With Quote
  #12  
Old 12-10-2014, 06:11 AM
Registered User
 
Join Date: Jun 2013
Posts: 21
hallo james on my fuse box i had blue fuse 25A its related to blower motor.does their is a specifc connection wire or electric plug can i trace and follow it to locate the strip fuse.
Reply With Quote
  #13  
Old 12-10-2014, 10:50 AM
JamesDean's Avatar
Electrical Engineer
 
Join Date: Apr 2005
Location: NE Ohio
Posts: 5,034
Quote:
Originally Posted by ali112 View Post
hallo james on my fuse box i had blue fuse 25A its related to blower motor.does their is a specifc connection wire or electric plug can i trace and follow it to locate the strip fuse.
If you have a fuse in the box for the blower then you will not have a strip fuse.

So you have no fuse on/near the shock tower that looks like the one below?



I was under the impression that MB moved to this solution for the blower motors after 1985. Now maybe you are right and that it was on US market and not european models...I'm not sure.


Can you take some photos and post them up? Of your shock tower area and of your fuse box blower fuse, lid and fuse location paper?
__________________
Cruise Control not working? Send me PM or email (jamesdean59@gmail.com). I might be able to help out.
Check here for compatibility, diagnostics, and availability!

(4/11/2020: Hi Everyone! I am still taking orders and replying to emails/PMs/etc, I appreciate your patience in these crazy times. Stay safe and healthy!)


82 300SD 145k
89 420SEL 210k
89 560SEL 118k
90 300SE 262k RIP 5/25/2010
90 560SEL 154k
91 300D 2.5 Turbo. 241k
93 190E 3.0 235k
93 300E 195k
Reply With Quote
  #14  
Old 12-10-2014, 02:39 PM
Registered User
 
Join Date: Jun 2013
Posts: 21
Ok James,sure You're welcome i will take some photos tomorrow.James the 25A fuse was broken from a long time ago when i turn the blower motor speed,Is it possible to be a short-circuit exists on HVAC Blower Motor Resistor regulator,now the fuse doesn't burn but it may be regulator is Fully crash.
Reply With Quote
  #15  
Old 12-10-2014, 03:34 PM
JamesDean's Avatar
Electrical Engineer
 
Join Date: Apr 2005
Location: NE Ohio
Posts: 5,034
Quote:
Originally Posted by ali112 View Post
Ok James,sure You're welcome i will take some photos tomorrow.James the 25A fuse was broken from a long time ago when i turn the blower motor speed,Is it possible to be a short-circuit exists on HVAC Blower Motor Resistor regulator,now the fuse doesn't burn but it may be regulator is Fully crash.
In your car there is no blower motor resistor package. There is a blower motor regulator. This takes the place of the resistors.

It is possible for this to have died. It it located under the blower motor.

If the fuse is labeled for the blower motor and you've replaced it then I would pull the cover to the blower motor compartment and see if your are getting power into the regulator. Then see if you are getting a control signal from the push button unit.

You could also take the blower motor out and directly power it with 12V and see if it spins.

__________________
Cruise Control not working? Send me PM or email (jamesdean59@gmail.com). I might be able to help out.
Check here for compatibility, diagnostics, and availability!

(4/11/2020: Hi Everyone! I am still taking orders and replying to emails/PMs/etc, I appreciate your patience in these crazy times. Stay safe and healthy!)


82 300SD 145k
89 420SEL 210k
89 560SEL 118k
90 300SE 262k RIP 5/25/2010
90 560SEL 154k
91 300D 2.5 Turbo. 241k
93 190E 3.0 235k
93 300E 195k
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:02 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page