Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-09-2014, 05:36 PM
Registered User
 
Join Date: Aug 2010
Location: PA Philadelphia
Posts: 212
w123 heat only works when i turn key?

My heat only works in my 85 euro 300D when I start car and turn on heat then move my ignition key - just a tad to the left. Has anyone encountered this? What is the fix?

__________________
72 350SL, 73 450SL, 82 300TD,84 300SD, 85 300D
Reply With Quote
  #2  
Old 12-09-2014, 05:56 PM
79Mercy's Avatar
Registered User
 
Join Date: Mar 2008
Location: Florida
Posts: 4,131
You need to replace the electrical portion of your ignition switch. Very common problem i have seen it a lot.
__________________
1985 300TD Turbo Euro-wagon
1979 280CE 225,200 miles
1985 300D Turbo 264,000 miles
1976 240D 190,000 miles
1979 300TD 220,000

GONE but not forgotten
1976 300D 195,300 miles
1983 300D Turbo 175,000 miles

http://i42.photobucket.com/albums/e3...e485-1-2-1.jpg
Reply With Quote
  #3  
Old 12-10-2014, 07:33 PM
Registered User
 
Join Date: Aug 2010
Location: PA Philadelphia
Posts: 212
thx - very helpful
__________________
72 350SL, 73 450SL, 82 300TD,84 300SD, 85 300D
Reply With Quote
  #4  
Old 04-20-2015, 08:03 AM
Registered User
 
Join Date: Aug 2010
Location: PA Philadelphia
Posts: 212
never did get around to doing anything - then yesterday I met a guy test drive it (after I drove it and met him) and he kept turning key and now it goes all the way to the right and nothing happens. I am going up there this morning and making sure battery is fine and lites come on - and will see if glow plug lite will come on. My son says AAA will come out and do some repairs if I know exactly what to tell them.
__________________
72 350SL, 73 450SL, 82 300TD,84 300SD, 85 300D
Reply With Quote
  #5  
Old 04-20-2015, 09:37 AM
JimFreeh's Avatar
Benz addict
 
Join Date: Mar 2007
Location: Hampton Roads, Virginia
Posts: 3,354
I had this problem with my 87 300TD.

There are three parts to the "ignition" switch:

1. Lock barrel. This is the part the key fits
2. Flat connecting rod. This part joins part #1 with part #3.
3. Electrical switch. This part contains the contacts and a rotary arm that moves in concert with part #1, via part #2.

On my car, part #2 failed. It twisted, and did not allow the rotary arm in part #3 to make contact with the starter terminal.

For simplicity, I'm disregarding the steering column lock mechanism.....

Jim
__________________
14 E250 BlueTEC black
94 E320 Cabriolet Emerald green
85 300TD 4 spd manual dark blue
Reply With Quote
  #6  
Old 04-20-2015, 11:02 AM
TX76513's Avatar
Platinum Member
 
Join Date: Apr 2003
Location: Brandon, Mississippi
Posts: 5,203
Cleaning the copper contacts on the back of the ignition AND slightly pulling FWD the tabs to add more tension is a fix if you don't want to throw cash at a new one.

__________________
BENZ THERE DONE THAThttp://www.peachparts.com/shopforum/...c/progress.gif
15 VW Passat TDI
00 E420
98 E300 DT
97 E420 Donor Car - NEED PARTS? PM ME!
97 S500
97 E300D
86 Holden Jackaroo Turbo D
86 300SDL
(o\|/o)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:05 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page