Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-24-2002, 08:06 PM
misterzook
Guest
 
Posts: n/a
300 E air conditioning problem

I have a 86 300E and I am having a problem with my air...the system was recently retrofitted and charged with freon...here is the problem...it will blow cold air at times however it suddenly stops working on its own or if you make an adjustment on the climate controls it will stop working, then when you start the car again, it might be working or it might not....Help!
Reply With Quote
  #2  
Old 04-25-2002, 12:21 AM
Ashman's Avatar
Registered User
 
Join Date: Sep 2000
Location: Sherman Oaks, CA
Posts: 4,748
Your AC pushbutton control unit could be having a problem, or you have another problem elsewhere.

I would search on this and see what you come up with. I think others have had this issue before.

Hope that helps in your search for proper working AC.

I'm not a tech, but I think I remember reading about similar issues with faulty ac controls..

Alon
__________________
'92 300CE - Sold
2004 C240 - C7 Wheels - Android Radio
2015 ML350 - P1, Pano, Ash poplar wood, Sport Dinamica interior, Running Boards Keyless go.
Reply With Quote
  #3  
Old 04-25-2002, 01:06 PM
Registered User
 
Join Date: Jul 1999
Location: Youngstown, OH
Posts: 150
Mine did the same thing and it turned out to be the blower motor resistor which is beneath the windshield wiper. I would strongly suggest you take it to someone to properly diagnose the problem before you start randomly replacing parts or waiting until you burn up a blower motor or more expensive part.

Intruder
Reply With Quote
  #4  
Old 04-25-2002, 01:54 PM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
ON cars with a compressor control relay; when the car has to be restarted for the A/C compressor to operate, the relay is getting a signal that the compressor speed is not equal to engine speed.
In other words BELT slippage OR compressor seizing.
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:01 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page