Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-04-2015, 08:52 AM
Registered User
 
Join Date: Feb 2015
Posts: 2
1992 MB 500sl

Good morning to all! Have purchased a project car a 1992 500SL. Replaced fuel pumps, filter- drained tank, cleaned injectors, new rotor - cap and wires. Replaced both coils and changed oil -filter and plugs. Car now starts but does not idle and runs rich and does not idle. Have a pair of camshaft sensors on the way and will replace them. Not sure if the injectors or idle solenoid are good but am heading in that direction. As of now have not even driven the car. The cats were plugged and shooting flames out of them when I first was able to fire the car, cut them off and was able to run the engine up to operating temp but had to keep revs over two thousand. Looking for any and all assistance.

Reply With Quote
  #2  
Old 02-04-2015, 01:15 PM
Registered User
 
Join Date: Nov 2014
Location: Slovakia
Posts: 20
How about wiring harness? It did a lot of funky stuff when my was bad. Especially MAF sensor harness (ran ridiculously rich, sometime ridiculously lean but mostly very rich like almost WOT mixture when idling on one bank and the other was normal- as I have 2 separate cables to each MAF(600 SEC)- you have only one so that is probably the stalling). You have maf harness and injector harness in one piece not separate like mine. So check your harness, if you havent already.

Last edited by anticore; 02-05-2015 at 11:07 AM.
Reply With Quote
  #3  
Old 02-04-2015, 07:56 PM
MTI's Avatar
MTI MTI is offline
Registered User
 
Join Date: Nov 2002
Location: Scottsdale, Arizona
Posts: 10,626
Have you confirmed the compression in the cylinders? burnt exhaust valves could explain your idle issue as well.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:58 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page