Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-27-2002, 12:36 AM
arif's Avatar
Registered User
 
Join Date: Apr 2002
Location: Los Angeles
Posts: 138
1993 500 SEL problems

recently acquired this car.. has 126k miles, all dealer maintenance records and is black on black.....can anyone comment on problems to expect with this car, and what to look out for?????? thanks
__________________
1993 500SEL
Reply With Quote
  #2  
Old 04-27-2002, 01:16 AM
Registered User
 
Join Date: Dec 2001
Location: Chicago
Posts: 100
Power Steering System and Evaporator for your A/C.

Other wise it is a great car. Out of all the models that that Benz produced I like that one (W140) the best. Mine is the bit lower end.
__________________
1993 400SEL (W140) 281K
1999 S500 (W140) 163K (Sold)
2002 S500 (W220) 72K
1999 S500 (W140) 88K
You cannot simultaneously prevent and prepare for war.
Albert Einstein (1879 - 1955)
Reply With Quote
  #3  
Old 05-08-2002, 11:34 AM
Registered User
 
Join Date: Nov 2001
Location: Lisbon, Portugal
Posts: 42
Hello Arif

I don't want to frighten you but I bought mine S500 one year ago with the exact same mileage of yours and since them I already done the following works:

1) Replace the switch at the gearbox, made the ASR light comes on and the engine loses power, very hard to find out;

2) Replace motor mounts, with 126kmiles they are gone for sure, makes o lot of difference;

3) Replace the electronic adjust throttle sensor;

4) Replace the complete cablage that connects the modules box to the engine, quite expensive but these cablage really turns bad with age, check yours;

5) Replace main fan hydraulic clutch;

6) Replace thermostat, very important with these mileage is probably going to fail very soon, and can cause serial damage to the engine

7) Replace front suspension soft mounts, completely gone at 126kmiles;

8) Replace nitro cells at back suspension;

9) Replace complete transmission shaft, it had a permanent vibrations at around 60 mph;

10) Replace fuel pumps and fuel filter;

11) Several others little things, such as filters of all kinds, power window system, electrical antenna, key ignition...

I might had not too much luck with this one, but almost all these cars that haven't a rigours maintenance jobs, and believe me the dealer papers does not mean much, mine also have the complete history at the official Mercedes dealer.

Folgado
93 S500
Reply With Quote
  #4  
Old 05-12-2002, 12:51 AM
arif's Avatar
Registered User
 
Join Date: Apr 2002
Location: Los Angeles
Posts: 138
thanks Folgado.....

l checked the records (dealer receipts) on my car......pretty much everything on your list has been replaced except for item 5..... fan hydraulic clutch....... which makes me feel a little bit better!!!.
Thanks for posting the list.
__________________
1993 500SEL
Reply With Quote
  #5  
Old 05-13-2002, 06:41 AM
Registered User
 
Join Date: Nov 2001
Location: Lisbon, Portugal
Posts: 42
You can consider yourself a very lucky guy Arif!!

Mine is running fine now, this weekend I fulfil another 1000 miles.
It is for sure one of the best cars for travelling.
Does yours have ADS?

Folgado
93 S500
Reply With Quote
  #6  
Old 05-13-2002, 11:55 PM
arif's Avatar
Registered User
 
Join Date: Apr 2002
Location: Los Angeles
Posts: 138
Folgado,

one question:
how hot does your car run. l am almost always at 100C and sometimes at 110C on uphill drives or heavy traffic. Is this normal? some have told me 100C is normal. it has been hot here in LA, in the 95+ F range!!


PSdont know yet what ADS is. will look it up.
__________________
1993 500SEL
Reply With Quote
  #7  
Old 05-15-2002, 06:19 AM
Registered User
 
Join Date: Nov 2001
Location: Lisbon, Portugal
Posts: 42
Hello Arif

The optimum temp. is 90C but is perfectly normal to reach 100 or even 110C, this does not mean that It's good as a matter of fact it's bad, not only for the engine but mainly because of the wiring, vacuum lines, electrical connectors etc...
There is nothing to do about that, so dont worry too much, only never use pure water at the cooling system, that would damage the thermostat.

Folgado
93 S500
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:00 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page