Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-18-2015, 02:59 PM
Registered User
 
Join Date: Mar 2015
Posts: 1
fuel pumps

Hi. Need a little help. My 85 380se Mercedes quit running a few months ago and now it will not start. Before that, I could here a humming sound coming like from the fuel pump, at least I thought so. I don't here the fuel pump turning on. Is there a fuel pump inside the gas tank. I see one outside in the rear by the passenger side? AutoZone tells me there is one inside the tank. I don't want to put the tank down for nothing. If you think it could be something else please let me know. Thank you
Reply With Quote
  #2  
Old 03-18-2015, 03:16 PM
Registered User
 
Join Date: Feb 2011
Location: Modesto CA
Posts: 2,581
External pump only; none in tank.
The fuel pump relay is a frequent culprit.
Reply With Quote
  #3  
Old 03-19-2015, 11:02 AM
earl orchard's Avatar
Registered User
 
Join Date: Oct 2011
Location: Florissant MO
Posts: 225
HI all
i don't mean to high-jack the thread, but i have an 85 380se and it quit also, my tests seem to indicate that the fuel pump is not pumping, but during testing my ignition broke ,and i think it was going out for a while, my question is would a bad ignition keep the fuel pump from running?

thanks

kenny
Reply With Quote
  #4  
Old 03-19-2015, 11:42 AM
earl orchard's Avatar
Registered User
 
Join Date: Oct 2011
Location: Florissant MO
Posts: 225
Quote:
Originally Posted by M380benz View Post
Hi. Need a little help. My 85 380se Mercedes quit running a few months ago and now it will not start. Before that, I could here a humming sound coming like from the fuel pump, at least I thought so. I don't here the fuel pump turning on. Is there a fuel pump inside the gas tank. I see one outside in the rear by the passenger side? AutoZone tells me there is one inside the tank. I don't want to put the tank down for nothing. If you think it could be something else please let me know. Thank you
i watched a youtube vid were the guy puts a fuel pump in a126s didnt look to bad
Reply With Quote
  #5  
Old 03-19-2015, 12:31 PM
earl orchard's Avatar
Registered User
 
Join Date: Oct 2011
Location: Florissant MO
Posts: 225
that was my next step before the ignition craped out
Reply With Quote
  #6  
Old 03-19-2015, 01:10 PM
Registered User
 
Join Date: Feb 2011
Location: Modesto CA
Posts: 2,581
Quote:
Originally Posted by earl orchard View Post
HI all
i don't mean to high-jack the thread, kenny
Yet that is exactly what you and RobbyStan have done. Your digression has nothing to do with the OPs problem.
Reply With Quote
  #7  
Old 03-19-2015, 03:46 PM
Registered User
 
Join Date: Feb 2011
Location: Modesto CA
Posts: 2,581
RS:

#8 is a response to the high-jacker, eo, not to the OP, M380benz.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:10 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page