Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 05-03-2002, 03:00 PM
Posts: n/a
vacunm leak

I have a Merz 190d and the following thing are acurring, the enigin will not shut down, the power brakes are not functioning right, and the climate control is also not working. I have been advised that it is either a vacumn pump, or a vacumn leak. if it is a vacumn leak where should i start to look.
Reply With Quote
Old 05-03-2002, 06:04 PM
Live to Learn
Join Date: Mar 2002
Location: Raleigh NC
Posts: 145
The main vacuum hose goes straight from the vacuum pump to the brake booster. It should have a nipple on it about halfway.
Check at the nipple to see if you have vacuum (should be at least 16 hg of vacuum.If not,take the hose loose at the booster (17 or 19mm wrench) and plug the end.Check vacuum with it plugged.If still no vacuum,the pump is bad.
Mercedes Benz Master Tech
ASE Master Technician
Diagnostic Technician
Owner of "Behind the Star Inc."
Raleigh NC.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 07:20 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page