Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-09-2015, 06:52 PM
Registered User
 
Join Date: Dec 2013
Posts: 35
1978 6.9 Temperature Gauge Stopped Working

My temperature gauge recently quit. For the first few weeks I owned the car, the gauge worked fine but jumped a bit if mashed the accelerator and let off. Now it doesn't work almost at all. When I turn the key to run, I can see the needle jump from it's resting place to right below the first mark, but it doesn't normally move from there. I changed the temperature sensor right by the upper radiator hose and that didn't fix the problem, but now the electric fan always kicks on when the car is barely warm. Also, once in a while, the needle will dance around while I'm driving, sometimes reporting the correct temperature for a few moments. I know there's a temperature sensor in the WUR, does that feed the gauge? Or is there some other temperature sensor on this car?
__________________
1987 300SDL
Reply With Quote
  #2  
Old 11-09-2015, 07:22 PM
Daantjie
 
Join Date: Nov 2014
Location: Vancouver, BC, Canada
Posts: 72
The unit at the top radiator hose is the "212 switch", which lets the fan kick in when the coolant goes over 212 Fahrenheit and has nothing to do with the gauge. The sender unit for the gauge is at the back of the RHS bank of cylinders close to the firewall. You will see 2 senders. One is for the Cold Start Injector and the other is for the gauge. My guess is the sender is toast or the connection is poor after all these years.
Reply With Quote
  #3  
Old 11-15-2015, 07:15 PM
Registered User
 
Join Date: Dec 2013
Posts: 35
Thank you for the help! I was able to find the temp senders and I found that the wire for the gauge had separated from the connector. I re-soldered the connector and it works perfectly now!
__________________
1987 300SDL
Reply With Quote
  #4  
Old 11-15-2015, 10:54 PM
Daantjie
 
Join Date: Nov 2014
Location: Vancouver, BC, Canada
Posts: 72
Nice! I love simple fixes!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:47 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page