Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-02-1999, 10:25 PM
chris
Guest
 
Posts: n/a
My oil pressure gauge is giving me problems on my 1988 1.90E 2.3. Sometimes
at idle it is almost at 0. Then other times it is up around 25-30 at idle.
It appears to work fine as long as the car is moving I just get strange
readings at idle. If I give the car some gas it will come up right away. Any
thoughts? Also, what should the normal operating temp be on a 75-80 degree
day with the A/C running? Mine keeps climbing up around 110 and setting off
my AUX fan and cooling it down to around 100. Is this normal? I am in Dallas
and I am a little worried what will happen when I am sitting in traffic this
summer and it is a 100 + degree day.

Thanks,

Chris P.
  #2  
Old 04-02-1999, 11:46 PM
Benzmac
Guest
 
Posts: n/a
I usually see them running in the low 100 mark. The 190 2.3's run a little hotter than most Mercedes because of the electric fans instead of the more common fan coupling.

------------------
Benzmac:
ASE CERTIFIED MASTER AUTO TECHNICIAN
LEAD TECHNICIAN FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


  #3  
Old 04-02-1999, 11:54 PM
chris
Guest
 
Posts: n/a
Any info on the oil pressure problem?
  #4  
Old 04-03-1999, 11:57 PM
Benzmac
Guest
 
Posts: n/a
What oil are you using and what weight?

------------------
Benzmac:
ASE CERTIFIED MASTER AUTO TECHNICIAN
LEAD TECHNICIAN FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


  #5  
Old 04-04-1999, 02:39 PM
chris
Guest
 
Posts: n/a
I just got the car three weeks ago. I have yet to change the oil. I got all service records and it looks like it was Castrol 20w/50. Will this affect the gauge? What oil do you recommend?

Thanks,

Chris P.
Dallas, Texas
  #6  
Old 04-04-1999, 08:00 PM
M.B.DOC
Guest
 
Posts: n/a
Chris you need to have the oil pressure sending unit tested, the gauge should read at least 0.5(Bar). The engine fan should lock up before the aux. fan comes on except with the A/C on, then the aux. fan & engine fan should be on at the same time!!
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Excessive Pressure without overheating Sako83 Tech Help 31 04-13-2004 06:26 PM
Is this Oil Pressure still within normal? Don Atienza Diesel Discussion 5 11-14-2002 07:48 PM
M119 Oil Ps And Temp royaiii Tech Help 5 04-05-2002 08:05 PM
Oil ressure lperei01 Tech Help 4 12-05-2001 08:33 PM
Excessive smoke mmilner Diesel Discussion 2 07-16-2001 07:52 PM



All times are GMT -4. The time now is 05:40 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page