Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 05-08-2002, 02:28 PM
Posts: n/a
Dash Components gone except spedo 300E

all my dash components are gone. Fuses look fine. I'm hearing this whine come from the dash, I assume it's the low petrol warning sound, but I've never let it go past 1/4 tank so I'm not sure what the sound is. Anyway, any ideas? Odom doesn't work anymore either (darn German cars and their crappy odoms!).

Reply With Quote
Old 05-08-2002, 03:37 PM
Registered User
Join Date: Mar 2002
Location: Issaquah, Washington
Posts: 47
you might want to replace the fuses even though they don't look like they are blown. i had the fuel and water temp and econ. gauges go on my 190 and even though the fuses looked good i changed them and its works now. for the $.50 it cost its worth a shot. my odom. is toast too. has anyone tried to sell their car with a toasted odom? how do you confirm the mileage? ken
87 190E2.6
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 03:14 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page