Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-01-2016, 02:56 PM
just-n-time's Avatar
Registered User
 
Join Date: Feb 2006
Location: Louisiana266 Maloy Rd winnfield71483
Posts: 804
Cool 190E 2.6 running very rough with different injectors

HELLO FOLKS THIS IS GOING TO BE A LENGTHY STORY, I began with a fuel issue : well it really was an issue with the wiper(the very little brushes that make contact with the potentiometer) Yes you got it I broke one off. so I bought one on line and spent the time cleaning the mess. SO LETS START FROM THE BEGINING After clean up I replaced the pot with a new one dialed in at .76 then I began to set the fuel from the bottom of the fuel distributor after this I had to order another set of fuel lines because I broke one, the newer set came in but the lines had a much smaller nut it was 12 m/m and mine came in at 14m/m so now I had no choice but to pull six out of my 420sel after the install it runs but will not take the throttle and when you tickle it. It will take the fuel but most likely will bog down and stall. so do I need to pull the fuel back or is it going to be an air leek? I know just keep checking. NEXT WEHAVE A 0 AND ON OCASION A NEG.-0. THE ENGINE IS ROUGH RUNNING.
perhaps THE INJECTORS ARE THE TROUBLE. this may be a question for one of the hot roders in the house. thanks for replies

Reply With Quote
  #2  
Old 09-01-2016, 03:43 PM
optimusprime's Avatar
Trevor Hadlington
 
Join Date: May 2014
Location: Worcestershire in England
Posts: 1,251
I wad looking at this job done on Youtube Video . The guy fitted the pot .But did not lock up fully the screws And with the engine running , it was rough .At this he put a screwdriver down and twisted it under the pot to move the location till it ticked over like a watch. You problem was ,you should do things one at a time .Incase you have to back pedal .
Reply With Quote
  #3  
Old 09-01-2016, 05:44 PM
just-n-time's Avatar
Registered User
 
Join Date: Feb 2006
Location: Louisiana266 Maloy Rd winnfield71483
Posts: 804
thanks Trevor.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:05 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page