Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-18-2002, 09:31 AM
AusMB
Guest
 
Posts: n/a
Question Engine noise

My 1988 300E (M103) has had a rapid increase in engine noise. It is a grinding noise that seems to be coming from the water pump. I have also been losing water and woundering if this has got anything to do with it. If it is the water pump is it a relatively simple job to remove/fix?
Reply With Quote
  #2  
Old 05-18-2002, 09:50 AM
1992300e
Guest
 
Posts: n/a
bearings

Hi,
Sounds like your water pump bearings are gone. Probably loosing the water from around the shaft. I would think it's time for a new water pump.

Good luck,
Joel
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:35 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page