Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 05-20-2002, 09:47 AM
Registered User
Join Date: Feb 2002
Location: Kingston NY
Posts: 114
many thanks for 190e help

Just wanted to take a moment to say thanks to everyone for helping with my 190e. This is a great place with great people.

Unfortunately, my 190e is still not well. I have solved all my mechanical problems (I think). I have 152 PSI in all 4 cylinders, new injector seals, new camshaft, valve guides, just a whole lot of new parts, etc. Car will not idle smoothly or below 1500 and stalls as soon as I put it in D ot R. If I come to a stop sign it stalls. Pings on acceleration. I cannot hear any vacuum leaks, but suspect that it is a combination of that and bad timing. I am about to do the unthinkable.. send it to a MB mechanic. I am SO damned frustrated with the car. I have a lot of mechanical experience (rebuilt my 72 911 RS myself) but this car really eludes me. Does anyone have any last ditch suggestions before I flatbed the thing to a garage? I guess I could be classified as desperate.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 08:37 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page