Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-14-2016, 05:04 AM
chazola's Avatar
Registered User
 
Join Date: Nov 2003
Location: Dorset, United Kingdom
Posts: 1,239
M104 Warm Start Idle Issue

Hi, my M104 S124 320 with HFM ('93), has a slightly annoying issue- cold starts are perfect, with steady idle, driving is fine etc, but warm/hot starts (engine off for a few mins to up to an hour or so), it feel like I have a miss at idle with some trembling. After giving it a bit of gas and driving off, the car feels fine. Anyone had similar symptoms?

Fuel filter is new & recent, throttle body has been cleaned & linkage adjusted, Coolant temp sensor is new, plugs are new and correct type, coils recently replaced with new and bad bits of wiring harness replaced. Fault codes read show no faults in the HFM system memory.

__________________
1993 320TE M104
---------------------------------------------------
past:

1983 230E W123 M102
1994 E300D S124 OM606 (x2)
1967 250SE W108 M129
1972 280se 3.5 W108 M116
1980 280SE W116 M110
1980 350SE W116 M116
1992 300E W124 M103
1994 E280 W124 M104
----------------------------------------------
"music and women I cannot but give way to, whatever my business" -Pepys
Reply With Quote
  #2  
Old 12-14-2016, 05:59 AM
oldsinner111's Avatar
once a happy man
 
Join Date: Nov 2008
Location: bristol,tn
Posts: 5,826
inspect wiring harness,after checking to see if coil might have green corrosion.Mine does that sometimes.
__________________
plant, and animal life matter. human's had their chance.
Reply With Quote
  #3  
Old 12-14-2016, 06:07 AM
Registered User
 
Join Date: Dec 2016
Posts: 3
thông tin thực sự hữu *ch cảm ơn bạn nhé
Reply With Quote
  #4  
Old 12-14-2016, 10:07 AM
Registered User
 
Join Date: Feb 2007
Location: los angeles
Posts: 707
check fuel pressure regulator may be leaking and engine sucking up fuel causing miss, or leaking injector, both can be checked with fuel regulator
Reply With Quote
  #5  
Old 12-14-2016, 10:50 AM
Registered User
 
Join Date: Dec 2016
Posts: 3
thông tin thực sự hữu *ch cảm ơn bạn nhé

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:08 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page