Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-27-2016, 11:04 AM
Registered User
 
Join Date: Dec 2014
Location: Georgia
Posts: 1
Question 97 E420 misfire

I am looking for some assistance with an E420 that is misfiring. I have driven it 5-7 miles, sometimes when I come to a stop light it idles sporadically or shut off (has several times, but starts back up no hesitation).

I replaced the front brakes, rotors & sensors (needed replacing).


It still showed ASR ABS, ASR.SKID:
I replaced the MAP sensor, all vacuum lines (even under plume), fuel filter.


Now, there are no codes on in the instrument cluster!
But, after starting the car it still idles for about 15-20 minutes then start to act as if it wants to shut off.


thanks

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:47 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page