Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #2  
Old 03-31-2019, 07:51 PM
1987MBZ-560SEC Old School
 
Join Date: Mar 2019
Location: San Francisco Bay Area, Californication
Posts: 6
Looking for troubleshooting information for some DIY stuff for 1987 560SEC. Don't see where I fit in your breakdown. I believe I am looking for a W116. Anyway looking for HEADLIGHT troubleshooting. Headlights won't turn on but the High-beam indicator lamp on the dash is illuminated. All of the other lights work correctly. Cleaned and replaced all fuses and the grounds that I can find all look okay. If it is the switch, how do I determine and how would I replace.
I will have a number of other questions and will post my successes as I am in the process of restoring this beauty back to her showroom state and replacing parts, pieces, and anything I can with a part of better quality if one can be found. PELICAN... you are going to love me!!!!!
Reply With Quote
  #3  
Old 04-01-2019, 01:24 PM
Administrator
 
Join Date: Mar 2016
Location: Los Angeles, CA
Posts: 1,576
Quote:
Originally Posted by 1987MBZ View Post
Looking for troubleshooting information for some DIY stuff for 1987 560SEC. Don't see where I fit in your breakdown. I believe I am looking for a W116. Anyway looking for HEADLIGHT troubleshooting. Headlights won't turn on but the High-beam indicator lamp on the dash is illuminated. All of the other lights work correctly. Cleaned and replaced all fuses and the grounds that I can find all look okay. If it is the switch, how do I determine and how would I replace.
I will have a number of other questions and will post my successes as I am in the process of restoring this beauty back to her showroom state and replacing parts, pieces, and anything I can with a part of better quality if one can be found. PELICAN... you are going to love me!!!!!
Hello and welcome to the forum! Your car actually falls under the W126 platform. I would suggest posing this question in our Tech forum - we have an immensely knowledgeable community that will be able to assist in just about every step of the restoration process.
Reply With Quote
  #4  
Old 04-25-2019, 08:28 PM
"One with my 71"
 
Join Date: May 2017
Location: In a house
Posts: 300
Any info on W114 M130 engines?

The list has 250 (1971) but I don't see anything on the W114 chassis or M130 engine... am I missing it?
Reply With Quote
  #5  
Old 04-26-2019, 01:22 PM
Administrator
 
Join Date: Mar 2016
Location: Los Angeles, CA
Posts: 1,576
Quote:
Originally Posted by 1971 250/8 View Post
The list has 250 (1971) but I don't see anything on the W114 chassis or M130 engine... am I missing it?
We likely don't have any tech articles for that platform unfortunately.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:13 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page