Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-06-2017, 03:08 PM
Registered User
 
Join Date: Jan 2017
Posts: 72
W123 low/hi beam help

While in the process of getting all the electrical bugs worked out I got my headlights working but the switch for the hi/low beam doesn't seem to do anything. The hi beam stays on no matter what position it's in. So I was wondering if there was a relay or something else that could be causing this or do I need a replacement switch.

Reply With Quote
  #2  
Old 02-06-2017, 03:39 PM
Diseasel300's Avatar
Registered User
 
Join Date: May 2016
Location: Texas Hill Country
Posts: 4,938
Is this a Euro or US spec car? Their wiring differs. It would be a good idea to spend some quality time with a wiring diagram specific to your vehicle and make sure the wires are going where they are supposed to.
__________________
'11 Honda Accord EX - "The Daily" 69K
'83 500SL Euro - "The Money Pit" 116K
'91 350SD - "Diseasel Jr." 173K
'94 BMW 530i Touring - "BMWtf LoLwagen" 233k
Reply With Quote
  #3  
Old 02-06-2017, 07:01 PM
Registered User
 
Join Date: Jan 2017
Posts: 72
Yea it's euro and yes the wires are in the correct location. When I use the lever to switch to low beam the indicator light blinks but then stays on. Just wondering if it's common for these switches are a common failure. Also I thought I'd throw this in, that only my left headlight wiper works. It gets power and when I use the washer button the other pin gets power. I'm assuming it's bad but again I'm just wondering if there's anything I should look for.
Reply With Quote
  #4  
Old 02-06-2017, 08:39 PM
Administrator
 
Join Date: Mar 2016
Location: Los Angeles, CA
Posts: 1,730
Quote:
Originally Posted by mbenz280ce View Post
While in the process of getting all the electrical bugs worked out I got my headlights working but the switch for the hi/low beam doesn't seem to do anything. The hi beam stays on no matter what position it's in. So I was wondering if there was a relay or something else that could be causing this or do I need a replacement switch.

See if this diy tech article is useful in troubleshooting the light switch issue - if there is something else that you need answered, feel free to post a Comment just below the article and someone will get back to you with more detailed info. Best of luck!

Mercedes-Benz W123 Headlight Switch Replacement | W123 (1977-1985) | Pelican Parts DIY Maintenance Article


-Dmitry

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:01 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page