Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-08-2017, 11:25 PM
joegolden's Avatar
Registered User
 
Join Date: Aug 1999
Location: Dalton, Georgia
Posts: 898
Thumbs up 1997 e420 no start

So I have owned this beauty all of 48 hrs now. I have put 250 miles on it mostly freeway. It's been running like a champ! Until tonight.

I have an incredibly steep driveway with a sloped turn around. I cranked the car from the flat parking pad and moved it to the sloped turn around so I could drive my VW to the gas station. It is parked sideways in the turn around with passenger side pointing downhill. I was gone 16 minutes. Jumped in the 420 to pull it back up on the flat parking pad and she won't start. She cranks and cranks strong. But no fire. The CEL and low fuel gauge light are flashing at me while cranking. They also flash when key is turned to the acc position. I am assuming this is fuel related. Duh. I have over a half of tank fuel in her now. Should I push it and get it down the drive to the flat street and give it a shot? Or any other ideas? Thx. Welcome back to owning an old benz! I love it regardless
__________________
Current stable......
17' rogue SV 30k
08 9-3 SportCombi 145k
00 e430 164k


previous MB units..
01' e320 171k (regret sale)
91' 300d 2.5t 300k (sold to ecoofidaho)
79' 240d 177k (old yellow my avatar)
87' 300d 169k (junk but fast)
85' 300tdt 261k (RBM parts delivery)
85' 300dt 68k (one owner cream puff)
82' 240d 250k
84' 300dt 198k (sold to diesel don)
91' 190e 2.3 61k
88' 260e 140k
Reply With Quote
  #2  
Old 02-09-2017, 06:10 PM
Registered User
 
Join Date: Jan 2012
Posts: 7,486
The tank on this car is in the trunk above the rear axle, pickup is on the left side with fuel pump below the left rear door.

The lights blinking during cranking / key on but engine not running might not be accurate as the instrument cluster is electronic.

I'd say to check for fuel pressure / flow and pump operation.
Reply With Quote
  #3  
Old 02-09-2017, 06:11 PM
joegolden's Avatar
Registered User
 
Join Date: Aug 1999
Location: Dalton, Georgia
Posts: 898
Thanks you sir !
__________________
Current stable......
17' rogue SV 30k
08 9-3 SportCombi 145k
00 e430 164k


previous MB units..
01' e320 171k (regret sale)
91' 300d 2.5t 300k (sold to ecoofidaho)
79' 240d 177k (old yellow my avatar)
87' 300d 169k (junk but fast)
85' 300tdt 261k (RBM parts delivery)
85' 300dt 68k (one owner cream puff)
82' 240d 250k
84' 300dt 198k (sold to diesel don)
91' 190e 2.3 61k
88' 260e 140k
Reply With Quote
  #4  
Old 02-10-2017, 04:28 PM
joegolden's Avatar
Registered User
 
Join Date: Aug 1999
Location: Dalton, Georgia
Posts: 898
Well it started fine the next morning! I drove it to work this am. Made it thru kids carpool line. Drove 35 miles up the freeway to work. When I crossed the rough rail road tracks a mile from work she quit while running about 40 mph. Flashing check engine light. Blinking low fuel light. I coast into a parking lot where I left it all dAy. Just tried to go back over to where I left it and start it. No go. $50 tow the 1 mile to my office and that's where she sits now

I did not realize I bought a bastard yr model car. Should have read up in my v8 powered benzs before running out and buying one. Now I understand the phrase " a cheap benz is the most expensive one you can buy". Lol

I'm glad it's just a 3rd car beater
__________________
Current stable......
17' rogue SV 30k
08 9-3 SportCombi 145k
00 e430 164k


previous MB units..
01' e320 171k (regret sale)
91' 300d 2.5t 300k (sold to ecoofidaho)
79' 240d 177k (old yellow my avatar)
87' 300d 169k (junk but fast)
85' 300tdt 261k (RBM parts delivery)
85' 300dt 68k (one owner cream puff)
82' 240d 250k
84' 300dt 198k (sold to diesel don)
91' 190e 2.3 61k
88' 260e 140k
Reply With Quote
  #5  
Old 02-10-2017, 06:24 PM
Registered User
 
Join Date: Jan 2012
Posts: 7,486
Have you pulled the back seat out and checked wiring / battery / fuse block? There should be a bundle of red wires coming off the positive battery cable that feeds the car.

Also try to pull trouble codes if any. The blinking low fuel light may or may not be normal. I'm pretty sure the low fuel light on my 97 SL320 and 97 C280 are on when the key is on but engine not running as a test of the bulb.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:54 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page