Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-24-2002, 03:17 AM
Registered User
 
Join Date: May 2002
Location: Snohomish, WA
Posts: 20
93 500SEL Electrical Gremlins?

We just bought a 93 500SEL over the internet from a dealer which seemed to be in great shape. Physically it is. When the car arrived (shipped from Miami, FL to Seattle, WA) the speedometer wasn't working. No biggie, took it to a shop and had it diagnosed and the tranny pickup/sending unit was working fine. Had to either be the wire then or the cluster itself. Took a quick guess and barrowed a cluster out of a friends 94 S420(same part # according to Mercedes) to see. On top of that, once we removed the original cluster the ASR and ABS idiot lights had been removed from the dash. When we put in the barrowed dash not only did the speedometer not work, but the ASR and ABS lights lit up like a christmas tree. So I'm wondering if they are all related. I guess it could be the wire from the speedo pick-up to the cluster is cut or shorting somewhere, but that just seems doubtful to me.

We have been in communications with the dealer and to no suprise they are not claiming much responsiblilty. We have been haggling over the speedo replacement for 2 weeks now and have only been able to get $300 agreement to cover the fix. Now as of tongiht, the reason for the ASR and ABS lights coming on need to be addressed too. But dealing with the dealer is a seperate issue.

Anybody have a good place to start so I can keep the diagnostics bill from the service dept as low as possible? Could these all be related? The only option I can think of is that a stereo was just installed a few months before the car was sold to us. Could some mis-wiring of that cause a problem?

Reading from a search on the forum, it appears that the ASR ABS lights might be coming on because of a faulty brake light switch. Dealer error codes need to be pulled it sounds like.

Other than that, we are very happy with the car. I certainly will appreciate any suggestions that you all can offer.

Cheers!

Last edited by EmDee; 05-24-2002 at 03:40 AM.
Reply With Quote
  #2  
Old 05-24-2002, 09:07 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Many times when the BATTERY is disconnected OR jumped the protection fuse for the ABS computer will BLOW! That will keep the speedo from working & the ABS/ASR lights will stay ON.
This fuse is in a computer under the hood on the passenger side. The cover for this box must be removed & then check these fuses.
The box looks like it has a "OIL" cap but IT isn't!! Good luck.
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #3  
Old 05-24-2002, 12:34 PM
Registered User
 
Join Date: May 2002
Location: Snohomish, WA
Posts: 20
Funny you should say that...On the first day that we had the car the thing went completely dead once. When I checked the battery, the + terminal was pretty coroded and of course I pulled it off to clean it and put some grease on it. The speedo wasn't working before this, but I wonder if it had lost power from the battery before because of the corosion and thus throwing that fuse.

Thanks for the tip and I'll check it tonight when I get home.

On a nother note...when the lights are on, are the lights for the shift gears supposed to light up? I would assume they are. The lights for the switches for mirrors, windows, etc light up, but the gear selector lights don't show anything.
Reply With Quote
  #4  
Old 05-28-2002, 05:53 PM
Registered User
 
Join Date: May 2002
Location: Snohomish, WA
Posts: 20
Thank you so much, that was it. I popped the cover off and found the component with the 4 fuses in it. I'm assuming it was the ABS computer and each fuse is for each wheel. Anyway, pulled the first 3 and they were fine. My hopes were dwindling...then popped out the 4th and final fuse. Whadya know, blown! Replaced it and took the car for a drive. Whala! Speedo now works with the ASR and ABS lights off also. Thanks a ton and great tip!

2 other issues though, if anyone has the time to answer.

How to replace the lights for the gear selector area. At night there are no lights lighting up the R N D 2 1 in the shift area. All the switches have lights, but none in the shift area. Do you have to pull the whole ceter console out to get at it?

Second thing, the rear air/heat vent that comes off the back of the arm rest...does it only blow cool air or is it supposed ot blow warm air based on the temp setting of the climate control system? Right now it only blows cool air and the kids in the back seat get cold when we drive at night.
Reply With Quote
  #5  
Old 05-28-2002, 06:43 PM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
That vent is only for fresh/air conditioning. There is an adjustment for the vent so that it can be shut off completly.

There is a small light bulb in the gear shift housing that lights up the shifter.
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #6  
Old 05-28-2002, 08:53 PM
Registered User
 
Join Date: May 2002
Location: Snohomish, WA
Posts: 20
Thanks for the info on the rear air refresh/air conditioner vent.

As far as changing the light bulb in the gear shift selector, how does one do it? I can get the small gear shift surround out easy enough, but from there I don't know where to go. I really hope I don't have to pull the whole tranny cover/shift console off to do it.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:06 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page