Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-28-2002, 10:37 AM
NA300D226
Guest
 
Posts: n/a
Power seats won't work with door closed

I have recently repaired my driver seat (the cable that makes it go up or down) and now when I drive the car my power seats won't work, but will if the passenger door is open. I have tried searching on it and have returned nothing any help would be greatly appreciated thax.
Reply With Quote
  #2  
Old 05-28-2002, 11:53 AM
brookspw's Avatar
Registered User
 
Join Date: Dec 2001
Location: Nashville, TN
Posts: 551
Will they work with the door closed and the KEY in the ON position?

If so, that is how it is SUPPOSED TO WORK.

Basically, a child safety deal -- so a child can't play and get crushed between seat and steering wheel.

brookspw
__________________
1994 C280, dark green metallic
105k miles

1991 190E 2.6, Black
191,500 miles
(sold to another forum member)

2003 Chevy Tahoe LT, Redfire Metallic
105k miles

1989 Mustang GT Cobra Convertible
43k miles
Reply With Quote
  #3  
Old 05-28-2002, 12:21 PM
Gilly's Avatar
Registered User
 
Join Date: Mar 2001
Location: Evansville WI
Posts: 9,616
Need info on the year and model of the car.
Reply With Quote
  #4  
Old 05-28-2002, 12:24 PM
brookspw's Avatar
Registered User
 
Join Date: Dec 2001
Location: Nashville, TN
Posts: 551
Sorry, did not see the "when I drive the car" part. I guess you have the key in the ON position when you drive it, huh?

brookspw
__________________
1994 C280, dark green metallic
105k miles

1991 190E 2.6, Black
191,500 miles
(sold to another forum member)

2003 Chevy Tahoe LT, Redfire Metallic
105k miles

1989 Mustang GT Cobra Convertible
43k miles
Reply With Quote
  #5  
Old 05-28-2002, 08:38 PM
NA300D226
Guest
 
Posts: n/a
It is a 1987 w124 300D turbo
Reply With Quote
  #6  
Old 05-28-2002, 09:42 PM
Gilly's Avatar
Registered User
 
Join Date: Mar 2001
Location: Evansville WI
Posts: 9,616
First check fuse #2, if that's positively OK, then I would suspect either the power seat diode, or a wiring problem.
Gilly
Reply With Quote
  #7  
Old 05-29-2002, 02:43 PM
NA300D226
Guest
 
Posts: n/a
I know it has to be a diode Because the fuse is allright, How would I find and or repair the diode if possible?
Reply With Quote
  #8  
Old 05-29-2002, 04:02 PM
Registered User
 
Join Date: Apr 2001
Location: Central Oregon
Posts: 91
I had a similar problem with my W126 and got some very helpful responses. I tried to give you a link to the thread directly, but no success today.

Anyway, the Subject Title is: No Power Seats w/door closed

if you do a search for Old Blue as User Name, you will see it listed. It did not come up for me when I did a "subject search".

Based on my experience it is either:

A. The diode (which prevents power from energizing the seat motors unless the key is On - under normal operation)

B. A short under the fuse/relay box that is again preventing power from energizing the motors.

In my case it was a small short that the dealer diagnosed quickly. The diode gets bypassed when your door is open, allowing seat adjustment prior to sitting down. Therefore the diode is a logical check, and there is a good pic of what it looks like on my previous thread.

Good luck .... Michael
Reply With Quote
  #9  
Old 05-29-2002, 07:29 PM
dtanesq's Avatar
Registered User
 
Join Date: Oct 2000
Location: Northern California/Western Washington
Posts: 386
Don't know if this will help, but I had the same problem with a 1986 300E. Same chassis, I figure the same relay box. Replacing the diode was the fix. On the 300E, the diode is a little guy at the very back of a box of relays aft of the fuse box on the driver's side of the engine compartment. It's right up against the firewall next to the hood hinge, as I recall. The part is inexpensive and easy to replace (if you have small fingers). I dropped my failed one between the relay box and the firewall and never saw it again.
__________________
David

His:
2003 Dodge Durango SLT
2002 BMW E39 530i Sport
1988 Mercedes 300TE
Hers:
2003 Chevrolet Suburban
1999 E430
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:08 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page