Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-04-2002, 09:07 PM
Registered User
Join Date: Jan 2002
Posts: 352
Domino Effect on S420's Cats

Well what I thought was a problem with my ac system was my cats. My original thread was:

HELP HELP sulfur smell from the ac

I finally got it back from the dealer today. They found that the air mass meter was defective which was causing the car to run rich and this fouled the cats and o2 sensor. They changed both cats and 02 sensors. Ther said my O2 sensors were slow and reading a constant .6 V. But once they came to put back the rear and center muffler, they were unable to put it back due to rust. So, they switched out those parts too. My question is: Do I have to break-in these new parts with light driving or is normal driving better. I feel so lucky because my warranty is expiring in a month. With the new exhaust system, the growl following ignition is gone and is more sedate and quiet.
Reply With Quote
Old 06-06-2002, 02:31 AM
Registered User
Join Date: Jan 2002
Posts: 352
Has anyone else experienced this problem and should I break in any of these parts.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 12:58 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page