Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
LinkBack Thread Tools Display Modes
Old 04-30-1999, 08:28 AM
Steve Gray
Posts: n/a
I thought I would try for some advise on a problem that doesn't seem to affect the car's performance but is a aggrevation. I have a 1984 380 SL that when warmed up (about 30 minutes) has the oil pressure guage show 0 (Scale 0-3)when I have the car in drive and at a stop. If I place the car in 'park' the reading goes to about 1 1/2 (which is correct). When I accelerate, the reading goes to max (3) until I come to a stop and we start over again. The oil sender unit has been replaced twice (I thought the first replacement was bad also) with no luck. The car really functions fine with pressure etc. the first 30 minutes or so then crapple on the guage. Any suggests on this pesky annoyance?????
Old 04-30-1999, 10:04 AM
Posts: n/a
My 1985 500SEL oil gauge goes crazy at idle- vibrates like a tuning folk until I press on the gas, and then it goes to "3" and stays there until the next traffic light. I just keep checking my oil, and just ignore the bouncing red thing on my dash.

Old 04-30-1999, 01:05 PM
Posts: n/a
My 79 450SEL acts almost identical to yours, except that at a stop in drive it usually dips to around 13lbs not 0. Ive had it checked and pressure is always ok, so Ive lived with it.
Closed Thread


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
'86 190E 16V question PLEASE HELP OIL pressure gauge reading 0 bar!!! Clinton Tech Help 12 10-17-2012 10:30 AM
Oil Pressure Problem? Perhaps the gauge? blackmercedes Tech Help 5 04-20-2004 12:32 PM
My semi-definitive oil post JHZR2 Diesel Discussion 0 01-21-2004 12:25 AM
380 Oil Pressure MALK Tech Help 1 06-25-2003 04:42 PM
E420 bizarre oil gauge behavior (no really) johnp352 Tech Help 3 04-12-2002 10:00 PM

All times are GMT -4. The time now is 08:13 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page