Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-06-2002, 05:21 PM
Posts: n/a
86 300E fuel injectors: Clean or Replace???

I have a 5-speed 86 300E. When warmed up it seems to have a bad miss when taking off in 1st gear, making a smooth getaway hard to do unless I rev it over 1800 RPM. It's not too bad when cold. It idles steady at 700 RPM but doesn't feel smooth. I've checked or replaced most of the ignition system so I've narrowed it down to a fuel problem, namely clogged or dirty injector(s). The car has 150,000 miles. It has plenty of power above 2500 RPM so I don't think a clogged fuel filter is the problem. At only about $20 each, should I replace them or get a injection cleaning?
Reply With Quote
Old 06-06-2002, 08:24 PM
J.HIDALGO's Avatar
Registered User
Join Date: Jul 1999
Location: Jax, FL
Posts: 1,785
Replace them!

I did replaced mine. For what I read, the new ones have a different and better spray patern. I think they are made of copper. Mine were original so they were due. The cleaning is going to cost you probably half as much and you still are going to take them out anyways. Make sure you also replace the injector seals, they are cheap.
Good luck!
'86 300E
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 05:52 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page