Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-10-2002, 05:07 AM
Posts: n/a
Unhappy My w124 260e

I have started to have this bad overheating problem when I sit in trafffic my temp gauge goes off the scale until I turn my heater on high then it goes down. I flushed the radiator out but I don't know which it could be the viscous clutch or the radiator the car only has 100k on it and its an 87 I imported from germany. is the viscous clutch just connected with the one allen bolt in the middle to the engine or is there some other bolts I need to remove to get it off. the radiator temp feels equal all over no cold spots but I'm ready to replace it also. What is the chance the water pump fins are worn down someone said that could be the problem in another form but I highly doubt it. i also replced my rad cap since the old one didn't hold pressure. It's getting hot here in Cali so I want to fix it soon before I do more damage. Thanks in advance
Reply With Quote
Old 06-10-2002, 05:10 AM
Registered User
Join Date: Apr 2001
Location: Hawaii
Posts: 147

Have you tried changing the thermostat? A stuck thermostat caused my overheating problem.

1987 260E Charcoal Grey 157,000 Miles
1987 260E Forest Green 120,000 Miles
Reply With Quote
Old 06-10-2002, 01:34 PM
J.HIDALGO's Avatar
Registered User
Join Date: Jul 1999
Location: Jax, FL
Posts: 1,785
Is your auxiliary fan working?

There are some postings regarding your problem in the past. Do a search!
The thermostat is a good starting point...
'86 300E
Reply With Quote
Old 06-10-2002, 10:39 PM
Posts: n/a
Still have ???'s

I read all the post on the site and they seem okay for the problem but I'm wondering does it make a different that my car does not have those aux fans? I don't have A/C since I imported it from germany I drove it again today but it just seems too hot under the hood I'm in cali and It was sitting between 100 -120 thermostat is new and working properly what should the idle be mine is at 500 rpm Thanks in advance on another subject what is the possiblity of me putting an a/c system in by getting all the parts from a donor car or aftermarket anyone know or should I just deal with the heat. Only reason I imported it was that I have family in germany and it was their car prior and it only cost me 1000 canadian in taxes to import
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 03:03 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page