Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-10-2002, 09:31 AM
Registered User
Join Date: Jun 2002
Location: Monroe County, GA
Posts: 8
300 SD Auxiliary Fan/Air Conditioning Problem

Greetings to all from a first time poster.

I have a 1984 300SD and have read several discussions regarding the auxiliary fans on various models, but I still have a question.

On two occasions I have lost all freon. Both times occurred after driving long distances with good AC operation, stopped for about 45 minutes, and upon restart the AC would blow hot air. I had it recharged and the second time I was able to see that it had leaked out of the pressure switch on the side of the dryer in line to the condenser. I replaced the switch and was told that a possible cause for the switch to leak would be the auxiliary fan not working which would cause pressure to build to a damaging level.

I tried shorting the connector to the temperature switch on top of the drier and the fan would make a jerking motion but would not run. I was about to order a fan thinking it was bad when at idle in traffic the other day I heard it running. To be sure I pulled over and raised the hood. The fan was indeed running even though the AC was switched off. It will run while the ignition is switched on, but stops when you turn the ignition off.

My theory is that while moving down the road, there Is enough air flow to keep the AC line pressure normal, but when the engine is stopped and the fan turns off, this is when the pressure builds to the point of blowing out the pressure switch. I have not recharged the system since replacing the pressure switch because I want to wait until I get the fan questions answered.

Is the fan switched by both engine coolant temperature and freon temperature on this model, and if so what would cause it to run based on coolant temperature and not due to freon temp. Should it continue to run after the engine is switched off to cool the freon? Should the fan run when the AC temperature switch connector leads are shorted as is mentioned for some other models?

Thanks in advance for any ideas.

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 08:57 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page