Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-12-2002, 01:16 AM
Posts: n/a
W202 C Class Power Window

My W202 C 220 Mileage: 135558km both left and right power window is not functioning at all suddenly. I brought to the workshop and they said the motors are faulty. But I am dun believe because how could two motors be faulty at the same time. I checked the fuse and replace a new one but still fused. Can anyone tell me what is the problem?
Reply With Quote
Old 06-12-2002, 02:14 AM
amg280's Avatar
Registered User
Join Date: Apr 2002
Location: NY
Posts: 530
Check to see if any other fuses are blown. I know in my 420SEL, when the wiper fuse goes, so does the windows. Does anything else not work either?
93 300D 2.5 Turbo, Black/Palomino 273K
09 E350 Black/Black 41K
Reply With Quote
Old 06-12-2002, 02:20 AM
Posts: n/a
No, only the windows
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 05:38 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page