Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-20-2002, 01:02 AM
Join Date: Jan 2000
Location: Indpls.,IN. USA
Posts: 84
C280 A/C quits

I'm fighting a problem with the A/C on a 98 C280. After driving about a mile the compressor stops engaging. The belt is tight, the charge is right and the pressures are good. Turning the key off and then restarting starts the cycle again. The codes that are stored are random, no description codes. After clearing all codes the problem still exists but the codes change. I searched for matches in the datdbase but found no problems that sounded the same. Any ideas?
Thanks for your help, Rick
Reply With Quote
Old 06-20-2002, 08:08 AM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
You need to replace the ETS (evaporator temp sensor). When this sensor goes bad the compressor should run 90 to 120 seconds & then shut off. The MB part number is 210-830-05-72!
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 08:33 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page