Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-24-2020, 09:48 PM
Registered User
 
Join Date: May 2007
Posts: 36
Transmission Stuck in 2nd gear, '04 C320

I pulled out a 4" piece of metal (a broken off, side rail of my eye glasses) that had somehow slipped down under the 'shift knob boot' and into my gear selector unit. It was interfering with the shift lever and when I 'yanked' it out, the car jerked and defaulted to 2nd gear. All else works except she won't shift out of 2nd gear. My first thought was a new Gear Selector unit? Or, is there a 'computer module' that may have shorted, a fuse? Anyone?


Reply With Quote
  #2  
Old 08-26-2020, 02:01 PM
Registered User
 
Join Date: Jul 2011
Location: bellevue, wa.
Posts: 155
The EGS on that should have a couple of small electrical plugs on the front of it. It's possible that one or both may have come unplugged or damaged the wiring. I would remove the whole selector cover and take a look. If the indication for park, drive, reverse, neutral isn't showing on your instrument display when moving the selector, then your EGS isn't recognized and doesn't know what gear it's in and will put you in limp mode.
Reply With Quote
  #3  
Old 08-26-2020, 03:03 PM
Registered User
 
Join Date: May 2007
Posts: 36
The glasses frame was 'inside' the selector, in the works. The electrical plugs are outside. I do see the display so don't think that's it. Is 2nd gear limp mode? She drives fine...just wont shift out of 2nd. I had another MB and experienced 'limp mode'...was horrible. How about the unit in the boot? I pulled it apart and it looked fine...clean as a whistle. I did find a plastic bushing kinda thing down in, Brown, about size of a dime, 1/2" long with collar on one end. Transmission Stuck in 2nd gear, '04 C320-merz-gear-bushing.jpg

Last edited by Clarion; 08-26-2020 at 03:15 PM. Reason: insert pic
Reply With Quote
  #4  
Old 08-26-2020, 03:05 PM
Registered User
 
Join Date: May 2007
Posts: 36
Reply With Quote
  #5  
Old 08-26-2020, 03:52 PM
Registered User
 
Join Date: Jul 2011
Location: bellevue, wa.
Posts: 155
Yes. Second gear is limp mode. I would try and pull some fault codes from engine management and the TCU to see what's going on.
Reply With Quote
  #6  
Old 08-26-2020, 03:54 PM
Registered User
 
Join Date: May 2007
Posts: 36
Also, two extra wires when all done...brown and blue/grey coming from cig. lighter harness. Don't remember unplugging...don't see anywhere they would go? they are short and won't reach past the Gear Selector unit area but, I don't see any very small flat pins for them to slip on to? They Extra???

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:49 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page