Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-22-2021, 11:31 PM
Registered User
 
Join Date: Jan 2015
Location: Quebec City, Canada
Posts: 92
190E antenna won't go up but motor works

I am at the point where I am about ready to start driving my 1992 190E after 2 years of storage/fixing. The antenna on the car always worked flawless. I replaced the mast back when I bought the car and never had a problem.

Now when I turn on the radio, the antenna won't come out. I removed the antenna from the car and opened the cover. If I turn the motor by hand, the antenna goes up. If I plug the antenna back in the car, it automatically resets by going down to the lowest position. Therefore, the motor does work. I have power to the red wire. I also have power to the blue wire. I don't know the voltages as I checked with a test light, but I can check back later. My guess would be that the head unit (aftermarket, but it worked before) doesn't send the signal to lift the antenna, but that is the blue wire and I have power to that wire! Anything else to check?

Reply With Quote
  #2  
Old 02-23-2021, 03:36 AM
280EZRider's Avatar
No Dumping
 
Join Date: Jul 2007
Location: Southern Oregon Valley
Posts: 1,599
Try pulling up the antenna by hand immediately after starting it electrically. If after giving it a running start and it continues upward on its own even if slowly, it's probably the bearing on the pinch roller that pushes against the mast at the wheel. Those little bearings tend to get gunked up and in turn need a good cleaning and re-lubrication.

__________________

Don't Chrome them; polish them
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:42 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page