Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-30-2002, 09:55 PM
Registered User
 
Join Date: Nov 2000
Location: Ontario, Canada
Posts: 463
I broke my gas pedal!!!

I am not sure how the heck this one happened but it did indeed break.

I was passing someone, hit the kick down and after I passed the person I noticed the engine slowly returning to idle with no pedal feel.

The pedal just flops back and forth to the floor and back. Car starts and idles perfectly, as before.

Did I break the linkage?

What should I look for?

Can someone please help me out?

I need a quick fix since I work on Tuesday.

Monday, thankfully, is Canada Day.

Please Help!!!

Mike McKinney
__________________
190E 2.6 - 244 000 km
Reply With Quote
  #2  
Old 06-30-2002, 10:01 PM
WRM WRM is offline
Registered User
 
Join Date: Jun 2002
Location: BURBANK CA
Posts: 151
there is a small rubber bushing on the throttle cable under the air filter housing. remove the housing, locate the throttle cable end & you should be able to find the bushing. try to secure the cable back in with a plstic wire tie until you get a new bushing. cost is about $ 2.00.
Reply With Quote
  #3  
Old 07-01-2002, 01:38 PM
Registered User
 
Join Date: Nov 2000
Location: Ontario, Canada
Posts: 463
WRM

How did you know that?

That is exactly the problem.

I didn't have any wire ties so I pulled out the engine degreaser and cleaned up the area, the bushing is sort of roted so I got of all things a BREAD TIE and put it over the cable with some play doe in front of the bushing before the little metal plate that the bushing is supposed to attach to.

It is holding for now so, I'll cross my fingers until my new bushing is available.

WRM, a sincere thank-you for your help.

Much appreciated!!!

Mike McKinney
__________________
190E 2.6 - 244 000 km
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:36 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page