Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-14-2002, 02:15 AM
sms sms is offline
Registered User
 
Join Date: Dec 2001
Location: Hartford
Posts: 134
Question Bent suspension member on 560sl???

Hi,

I recently purchased an '87 560sl and discovered later that the car was leaning on the passenger side. I though it was the rear springs and replaced them, but of course that wasn't the problem. I then looked at the front end and removed the shocks and front stabilizer bar to see if they were causing the problem. Well, when I removed the bar the car leveled out, but I'm not sure if I have a bent bar or bent bracket.

Can anyone tell me if the bar is supposed to be symmetric or not since mine certainly is not?

Thanks,

Steve
Reply With Quote
  #2  
Old 07-15-2002, 10:05 AM
sms sms is offline
Registered User
 
Join Date: Dec 2001
Location: Hartford
Posts: 134
Hi,

Does anyone know the answer to my question? I'm just trying to verify if my front stabilizer bar is bent on my 560sl. It seems bent, but I'm just going by the fact that one end is shaped differently from the other.

Are both ends supposed to be the same shape (symmetric)?

Thanks!

Steve
Reply With Quote
  #3  
Old 07-17-2002, 12:35 PM
Member
 
Join Date: May 2002
Location: Des Moines, Iowa
Posts: 64
HI Steve

I don't get in here much so sorry for the late reply. I have run in to the front sway bars on 107s' causing just what you have. Yes the bar should be th same on both ends. I can't tell you why this happens but it does. Since sway bar is really a big spring I would suspect that it has been sprung some how. Replace the sway bar and all will be well. Of course put all new rubber mounting hardware on it too.

fasthair
Reply With Quote
  #4  
Old 07-19-2002, 05:35 PM
sixto's Avatar
smoke gets in your eyes
 
Join Date: Jun 2000
Location: SF Bay Area
Posts: 19,751
There's a recall on R107s having to do with cracked front subframes or something like that. Do a search.

Sixto
91 300SE
87 300SDL
Reply With Quote
  #5  
Old 07-20-2002, 01:53 AM
Jason M.
Guest
 
Posts: n/a
I had a negative camber problem on a W124 that just wouldnt straighten out... springs, ALL new multilink arms with bushings... yes including the non adjustable camber arms... everything...

So I had a mercedes/bmw body shop that uses sonar measuring systems and a frame machine look at it, and the subframe had actually sagged outta shape. couple of chains and a hydraulic ram later... it was fixed perfectly within specs.

This may not be the problem with yours, but I've seen this problem on other Mercs. that havent been fixed w/ springs,bushings, etc


Jason McNeese
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:50 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page