Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 07-23-2002, 10:22 AM
mpc mpc is offline
Registered User
Join Date: Jul 2002
Location: North Wales, PA
Posts: 8
Angry 89 300E Replacement Tumbler won't always "Catch"

Thank you all in advance for the help you have been in the past! I have replaced the '89 300E Ignition Tumbler exactly as instructed from the great advice given on the topics. The Ignition worked perfectly for about two weeks, then yesterday the key only spun from the "0" to "3" position. After several attempts, I realized that when the key is in position two I could just pull the tumbler and collar assembly out ( I did not as I had no tools). I rotated the collar a bit and pushed the key and tumbler in further and the car was able to start. It seems as though the keeper spring has not caught on anything (This tumbler as well as the original only has one spring). Other than this the thing works fine! When the ignition is turned to position three there is spring felt in the key backing it off from the start postition (there was no spring-back when the key only rotated), the steering wheel lock works fine. Any suggestions ? Thank you all in advance for your help.

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 09:03 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page