Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 07-23-2002, 03:41 PM
Registered User
Join Date: Aug 2000
Posts: 71
300SE emissions report

I recently acquired a 1989 300SE with 160k miles (beautiful car, in general in very good to excellent shape). due to various reasons (not inherent problems with the vehicle), the head gaskets had to be replaced, as well as the timing chain and two valves. I have two questions. First, I wanted to know if the following is a concern. In drive at idle, the economy meter goes to halfway. when I accelerate to around 25 mph and take my foot off the pedal, the economy meter goes to the far left. Is this normal? In Park, the needle holds steady around the first c.

Secondly, this vehicle barely passed emissions. I inquired the buyer about it and they said this was normal for a car of this age. I am inclined to be skeptical of this based on what a friend told me.

CO %
limit .79
reading .33

HC ppm
limit 140
reading 103

NO ppm
limit 1046
reading 1034

I am just concerned that next year, I will get a failure on the NO or the HC.

Thanks for any help you can give.
Ben K
Reply With Quote
Old 07-23-2002, 08:21 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
If you fail next year, you could get a new catalyst installed. I have seen that if the engine burns ANY oil at all, the cat will not work well and it will FAIL emissions.
Donnie Drummonds
Reply With Quote
Old 07-23-2002, 08:47 PM
Registered User
Join Date: Aug 2000
Posts: 71
it should not be burning

I understand.
What does the cost of installing catalyst run? Would the EGR cause a problem? It should not be leaking as head gasket cover was replaced, valve seals were replaced as well as head gasket itself and timing chain due to screwup in labor. You would not worry about it before next year? My tech friend said it is not normal for them to be running with those numbers from his experience. He said it may be the cat, although he kinda doubted it. pays to find out though. I just hope it isn't the cat. Thanks much

Ben K
currently just 1989 300SE 185k miles
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 12:14 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page