Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
LinkBack Thread Tools Display Modes
Old 06-02-1999, 09:50 PM
Posts: n/a
Currently have 252K miles on my 300sd. Though I have several questions.
#1 Battery and Brake pad indicators in the dash do not glow when going to crank the engine (but the glow plug indicator do light up). As soon as the engine starts the glow plugs indicator turn off, but the battery and brake indicator start flickering, sometimes stops lighting up under hard acceleration. I have replaced all the fuses (red/white/blue), also I have check the back of the alternator for a secure connection. I have not noticed any loss in battery power, so I assume the alternator is charging the battery.
# 2, Suddenly my high beams (both sides)stop working, but low beams work fine. Even with new lights problem still occures and I have replace all the red/whit/blue fuses and still have the problem.
#3, From a past article posted several months ago, a member who had a 190E had a problem with a screeching noise from the dash board. The only to stop the noise was to hit the turn signals (which stops the noise only for a few seconds). A recommendation by a tech in this forum was to replace all the fuses (red/white/blue), which will stop the screeching sound.
I have done the suggestion, but the noise is still there... any other suggestions?

All responses will be greatly appreciated....


Old 06-03-1999, 12:04 AM
Posts: n/a
First your battery & brake pad indicator is on dash after the engine is running....I will
say your alternator is bad check your charging system.
#2 it could be your high beam switch or relay
#3 it should be your turn signal switch.
hope is help !
Closed Thread


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
rear glass 300SD shadetree77 Diesel Discussion 3 08-15-2003 01:49 AM
W116 300SD and W126 300SD comparison? ericnguyen Diesel Discussion 11 07-11-2003 01:11 AM
Desperately Seeking a 300SD!! diesellady Diesel Discussion 14 08-28-2002 01:19 PM
81 300SD in SF Bay Area now on ebay sixto Mercedes Cars For Sale 0 04-06-2002 01:56 PM

All times are GMT -4. The time now is 01:50 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page