Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
LinkBack Thread Tools Display Modes
Old 06-04-1999, 11:19 PM
Posts: n/a
The light went on while driving on a hot NY day. Checked the dipstick, and added oil as needed. The light however has not gone out. I've checked the fuses, and they're ok.
Any info would be greatly appreciated.
Old 06-06-1999, 08:04 AM
Posts: n/a
The oil level sensor is in the left(drivers) side of the oil pan. Either it has shorted or the gauge is bad. Try unplugging the single wire on the sensor & see if anything changes.
Old 06-08-1999, 09:06 AM
Posts: n/a
MB Doc,
thanks for the info. I unplugged what I thought was the wire and reattached. The oil light went out, but the car took awhile to crank then finally start. Hope everything is alright.
Closed Thread


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil Additives Bill Wood Performance Paddock 6 08-24-2011 10:53 AM
Problem: The oil pressure light stays on toka Tech Help 4 11-22-2008 04:44 PM
HELP! Oil all over engine compartment! rjk Tech Help 33 04-16-2006 11:20 AM
Diesel Engine Break-in Mileage Mercedes Man Diesel Discussion 10 03-21-2002 11:57 PM
Oil Change Frequency mrbroche Tech Help 34 05-31-2001 11:03 PM

All times are GMT -4. The time now is 05:31 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page