Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-30-2002, 07:13 PM
Registered User
 
Join Date: Feb 2002
Posts: 29
alternator

I have a 260E with 175,909 miles. Last week, I was experiencing problems at stop lights and sitting in traffic such as the air conditioning, radio, and lights cutting off and the ABS and SRS lights coming on, and when I would stop the car I had to get someone to jump me. I took it to the mercedes dealer and they replaced the alternator and battery. This fixed it for a few days, then it started doing the same thing again. I took it back today, and they replaced the alternator and battery again (free this time since the old one was but a week old). On the way home, same thing. It cut off on me in downtown 5:00 traffic and I had to get someone to jump me When I got home, I immediately called the dealer (Beck Imports of the Carolinas) and my service advisor told me to bring it back in the morning and they would look at it. Anyone have their own opinion?

Matt
__________________
1988 260E
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:28 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page