Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-07-1999, 11:21 PM
mbz owner
Guest
 
Posts: n/a
Hello, I have an 83 300 SD with a temperature gage that seems to be malfunctioning. The gage will jump from 80C to 85C suddenly. Sometimes it will drop from 100C to 85 C suddenly. This seems to happen more if the A/C is switched on and off.

Has anyone else had anything like this? Shouldn't the temp gage make smooth transiitions?
I've checked the instr. panel for loose screws. No ground wires appear to be loose. Sensor was replaced 4-5 years ago with an aftermarket replacement.

Is this a grounding problem?
  #2  
Old 06-07-1999, 11:42 PM
Benzmac
Guest
 
Posts: n/a
It could be a grounding problem, but usually it is a faulty gauge if nothing else has fixed it.

------------------
Benzmac:
ASE CERTIFIED MASTER AUTO TECHNICIAN
LEAD TECHNICIAN FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


  #3  
Old 06-09-1999, 02:20 AM
mbz owner
Guest
 
Posts: n/a
Well, I actually ended up replacing the cluster with a new one.

It solved the car's "overheating" problem, the temperature is now in the normal range.

However, there still is a little bit of jumping in the indicator, esp with A/C switched on and off rapidly.

Might my aftermarket Car alarm have something to do with this? Or a defective temp sender?
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
300 D 2.5 coolant temp max381 Diesel Discussion 1 09-07-2004 09:07 PM
outside temp on dash display 300 sdl stangsteve Diesel Discussion 4 11-24-2003 09:48 AM
Low engine temp no heat razorman Tech Help 4 04-09-2002 06:59 PM
300 sd A/C flaps !! juan Tech Help 0 09-09-2001 04:44 PM
300 Td riseing temp stephenjjf Tech Help 5 04-08-2001 10:41 AM



All times are GMT -4. The time now is 06:48 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page