Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-05-2002, 01:04 PM
T.Lazenby
Guest
 
Posts: n/a
1985 500sel

my 85 500sel will not run i cheked for compression it was good im getting good spark and gas to the injectors. the only thing that i found was when i turn the key the fuel pump will not run but if you jump the fuel pump it will run. is there a sensor or somthing that is stopping it from running?
Reply With Quote
  #2  
Old 08-05-2002, 01:41 PM
awfrance
Guest
 
Posts: n/a
500 SEL

Check the fuel pump relay, should be a black box inside the fuse box just behind the firewall on the drivers side. Give it a tap with a screwdriver a couple of times and see if you can hear the fuel pump turn on. The fuel pump relay is the most common cause of the fuel pump not turning on. You can run tests on the relay, but i have no idea how to, maybe someone else can chime in with that answer!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:22 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page