Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
LinkBack Thread Tools Display Modes
Old 06-09-1999, 01:43 PM
Posts: n/a
I had my a/c rebuild late last summer. New York compressor, dryer, evaporator, one a/c hose rebuilt. Freon is full and system does not leak.

Temp from the vents is not very cold. On a really hot day here in Texas, the vent temp will get to the low 50s. It will cool lower, but it takes a very long time at highway speeds. Also my compressor almost never cycles. It stays on 95%+ of the time.

On the blower motor box there are 2 vacumn pots. One operates the fresh/recircluting air flap, and one that overrides the first that opens the flap to get about 20% fresh air even when max cooling is called for.

Why would you need to bring in outside air when max cooling is called for. Would it do any harm to disable the override pot so that the ONLY recirculated air is used. Maybe that would be colder.

Stephen C. Stierstorfer
Old 06-09-1999, 08:58 PM
Posts: n/a
Lets see, air cond system from the 1970s that cools; pretty good. Newer cars also allow 15-20 percent fresh air into the car. Fresh air is important for a "healthy" car. Many folks smoke & everyone must breath. The newest cars have filters to clean the air.
Old 06-10-1999, 11:44 AM
Posts: n/a
I would suggest disabling the recirc vacuum switch. I have done this on my 83 TDT and it has improved A/C performance. As far as the A/C not cycling, either it is low on freon or there is an electrical problem , MB or Benzmac, which relay controls this?

83 TDT 110K
Closed Thread


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
'84 300SD W126 - A/C clicks off dead once it reaches dialed in temp bodyart27 Diesel Discussion 7 08-12-2005 03:19 PM
Winters over and A/C season begins pdxman Diesel Discussion 7 03-13-2004 01:38 PM
91 300SEL - Idle drops when A/C is on Mike Murrell Tech Help 2 09-05-2003 08:27 AM
'84 300SD W126 - A/C Question - the saga continues bodyart27 Diesel Discussion 13 06-23-2003 05:32 PM
Bad odor from A/C and Refrigerant leakage Holson Adi Tech Help 5 01-17-2003 02:00 PM

All times are GMT -4. The time now is 02:19 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page