Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-09-1999, 02:43 PM
Stephen
Guest
 
Posts: n/a
I had my a/c rebuild late last summer. New York compressor, dryer, evaporator, one a/c hose rebuilt. Freon is full and system does not leak.

Temp from the vents is not very cold. On a really hot day here in Texas, the vent temp will get to the low 50s. It will cool lower, but it takes a very long time at highway speeds. Also my compressor almost never cycles. It stays on 95%+ of the time.

On the blower motor box there are 2 vacumn pots. One operates the fresh/recircluting air flap, and one that overrides the first that opens the flap to get about 20% fresh air even when max cooling is called for.

Why would you need to bring in outside air when max cooling is called for. Would it do any harm to disable the override pot so that the ONLY recirculated air is used. Maybe that would be colder.

Thanks
Stephen C. Stierstorfer
acje@flash.net
  #2  
Old 06-09-1999, 09:58 PM
M.B.DOC
Guest
 
Posts: n/a
Lets see, air cond system from the 1970s that cools; pretty good. Newer cars also allow 15-20 percent fresh air into the car. Fresh air is important for a "healthy" car. Many folks smoke & everyone must breath. The newest cars have filters to clean the air.
  #3  
Old 06-10-1999, 12:44 PM
SteveB
Guest
 
Posts: n/a
I would suggest disabling the recirc vacuum switch. I have done this on my 83 TDT and it has improved A/C performance. As far as the A/C not cycling, either it is low on freon or there is an electrical problem , MB or Benzmac, which relay controls this?

------------------
83 TDT 110K
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
'84 300SD W126 - A/C clicks off dead once it reaches dialed in temp bodyart27 Diesel Discussion 7 08-12-2005 04:19 PM
Winters over and A/C season begins pdxman Diesel Discussion 7 03-13-2004 02:38 PM
91 300SEL - Idle drops when A/C is on Mike Murrell Tech Help 2 09-05-2003 09:27 AM
'84 300SD W126 - A/C Question - the saga continues bodyart27 Diesel Discussion 13 06-23-2003 06:32 PM
Bad odor from A/C and Refrigerant leakage Holson Adi Tech Help 5 01-17-2003 03:00 PM



All times are GMT -4. The time now is 08:00 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page