Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-14-2002, 11:56 AM
Registered User
Join Date: Oct 2001
Location: Raleigh, NC
Posts: 51
92 400E Oil Pressure Check Valve Replacement

92 400E, 136,000 miles. Just began hearing a 1-2 second chain noise at cold start only. After searching the tech forum, Benzmac and others have suggested that many times this is caused by a faulty oil pressure check valve located in the oil filter housing.

My question: Has anyone here done this job themselves ? How difficult is it to remove the oil filter housing and replace this valve ?

Any suggestions/tips are welcome.

Reply With Quote
Old 08-14-2002, 02:30 PM
aldedmon's Avatar
Senior Member
Join Date: Mar 2001
Location: Houston
Posts: 808
Yeah , lots of us have done it

Its not too difficult. It has 3 allen head bolts that hold the housing to the block. I dang near stripped one and the dealer was no help in replacing the bolt so I had to reuse. If you begin to strip yours, and yopu need to remove them use a 12pt 10MM socket and tap it gently over the bolts. They will come out easily using the method.

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 04:28 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page