Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-15-2002, 12:10 AM
Registered User
Join Date: Oct 2001
Location: Tampa
Posts: 73
AC stops blowing - 500E

In the past couple of days, my blower has intermittently stopped blowing. I've experienced: (1) the blower not work upon starting the car; (2) the blower working fine and blowing cold, only to stop, and then start again after several minutes of messing with the controls (I don't think messing with the controls has anything to do with the AC coming back on); (3) the blower blowing hot air, although this hasn't happened as recently as (1) and (2).

When it fails, I do not get any blown air across any of the buttons except that I get a small trickle of cool air when I push the Economy AC button. It seems like it's letting out a little bit of trapped air and eventually stops.

I'm going to check the fuses, but wonder how a fuse could allow intermittent failure. Any help would be greatly appreciated. I live in Vegas, where it's 110 degrees and life without AC is intolerable.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 12:12 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page