Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-19-2002, 12:26 AM
Registered User
Join Date: Jul 2002
Location: Arizona
Posts: 12
My 300e is driving me crazy!

I really need help with this problem. I just replaced my 86 m1o3 engine (due to piston/valve contact) with an 88 m103. Everything went well until the engine ran for ten mins. and started knocking. I assumed it was a lifter caused from the engine sitting for some time before installation, but my neighbor who has rebuilt several enigines said it was a rod or main bearing. the bearings had a little wear and the rest of bottom end looked fine.
I replaced the bearings and installed the engine and still have the same knocking noise.
I guess my question is, how loud of noise does a bad lifter make? I thought lifter noise was more of a ticking sound. I am almost to the point of selling the car as is.
If anyone in the Poenix area knows any good mechanics please let me know. Closer to east valley the better.

Thanks everyone,

Reply With Quote
Old 08-19-2002, 12:33 AM
Registered User
Join Date: Jan 2001
Location: oregon
Posts: 2,013
I use a stethascope and a dowel rod to locate source of noise you can pin point it pretty well..... William Rogers.....
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 04:34 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page