Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-05-2002, 12:31 AM
Registered User
Join Date: Aug 2002
Location: Fair Oaks, CA
Posts: 50
Question Front License plate E300

I made the mistake of trying to put the front license plate on. Removed the plastic frame the one the holds the sensor to see what was keeping the screws from going thru and found the metal plate that a-lines the plastic frame to the bumper has offset that don't match the hole so I take it off. Big mistake when I realize that doesn't help I try to put it back on snug and low and behold it looks like crap now. I have a 1/2 gap will not fit. Let alone I still don't have the plate on. Any Ideas please. Do I need to drill new hole or am I going too far. How did Mercedes make it fit?
Thanks for any help
Dave Myers
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 09:56 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page