Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-09-2002, 12:21 AM
Posts: n/a
89 300 TE hard start

I have an intermittent starting condition on my 1989 300TE with 175K miles. It starts every time I turn the key however, on some mornings is stalls about 2 to 4 seconds after I release the key. Even if I rev the engine 2000 to 3000 rpm it still stalls with the same symptoms. The car may do this 10 times or more and it can be quite annoying. I suspect there is an electrical problem but have not isolated it since it is intermittent. Fortunately, I have another parts car and have swapped the following used parts with no change in symptoms.

overvoltage relay
battery(with cleaned terminals)
CIS-E fuel control unit (black box)
idle speed control unit
ignition switch (brand new)(recommended by local MB mechanic)
unplugged factory security system
gear selector starter safety switch
cold start air valve(recommended by local MB mechanic)

I understand from some of my service books that the air conditioner compressor typically is "on line" 4 seconds after the engine starts. The stalling occurs even with the climate control switched off.

I had considered removing fuses on various circuits believing that an electrical load is switching on causing the ignition system to shut the engine off. The ABS system is not fully functional as I found the dash lamp removed shortly after I purchased the vehicle a year ago.

Does anyone have any ideas?
Reply With Quote
Old 09-09-2002, 02:21 AM
pmizell's Avatar
Benz Zealot
Join Date: Jun 2001
Location: Houston, Texas
Posts: 838
Sounds like your fuel accumulator could be going bad. Do you have this starting problem at all when the engine is warm?

How does the engine run once started? Possibly try and run some fuel injection cleaner thru your fuel system to see if that helps your starting woes.

Good luck..
'01 E430, Sport 72,000 mi
'98 C280, 126,500 mi
Reply With Quote
Old 09-09-2002, 10:32 AM
it leaks, its german
Join Date: Mar 2002
Location: raleigh nc
Posts: 1,111
Fuel pressure leak test time. :-)

Sounds like a internal leak. Posible sources are injectors, cold start valve (long shot), fuel pump check valve and accumulator.

Project Smoker, '87 603 powered wagon
Hauler, 96 CTD can you say torque?
Toy 73 Cougar xr7 convertible
Acme Automotive Inc.
Raleigh NC
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 08:39 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page