Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-10-2002, 09:52 AM
Posts: n/a
Question 85 190E cutting off mysteriously

Hello All,

New to the forum here. Great board.

I have an 85 190E with little troubles until this morning. Started the car and within 1 minute the gauges began flickering up and down (oil pressure, temp, fuel) and I could hear a clicking noise sounded like under the dash. Well normally this would not be a big problem, but the engine also shuts off everytime it clicks. So I went down the road in it and while driving, there it went again, gauges clicking up and down and the motor shutting off. Well if I am going down the road and it keeps flickering for about 10 seconds then stops the engine will continue running. I am at a loss? Any one know what this is?

Thanks for any help

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 04:19 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page