Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-11-2002, 12:59 AM
Posts: n/a
300 sl engine sputter

I just bought a 1991 300sl and love the car. Although I have one (maybe two) frustraring problems. When starting the car it will immediately stall. The second hit of the key the car will start and sputter for a few seconds and sometimes stall. There is a smell of gas in the garage. The previous owner took the car to a shop and they replaced the timing chain. That shop told me the next step would be to replace the two fuel pumps($500) I took the car to another shop and he thought it was the fuel injectors. He cleaned them and replaced the filters($400) The car runs the same. Now he wants to replace the injectors($500) Im not sure what to do. Any suggestions? Are the injectors easy to replace? Do they require any tricks or special tools? the car has 140000 miles. After starting and running for a minute the car runs perfect.
Reply With Quote
Old 09-13-2002, 05:24 PM
Registered User
Join Date: Jul 2002
Location: Ojai, Ca.
Posts: 66

I have a 1990 300 SEL. I think we have the same engine and we definietly have the same problem. You didn't mention if you had trouble with cold start, hot start, or both. I am assuming you have a CIS system on your car. There are numerous fuel injection checks you can make but you will need a pressure guage and troubleshooting procedure. Items that can effect starting include the fuel pump & check valve, accumulator, cold start valve, electro-hydraulic accuator (EHA), and fuel pressure regulator. If these items check out, I read recently in Mercedes Enthusiat that cold solder joints on the controller circuit boards or failing electrical connections can also cause misleading problems. Keep after it and post back if you solve your problem.

Reply With Quote
Old 09-16-2002, 02:09 AM
Posts: n/a

It realy doesnt matter whether the car is hot or cold it sometimes will start right up and then sometimes it takes a few hits of the key. then is will sputter for the initial take off and will stall if you dont feather the throttle. After the car will run perfect. the mechanic checked the fuel pumps and couldnt find a problem. He wants to replace the injectors which im sure i can do myself. I havent heard of electrical problems. I heard that the coolant temp valve? might be a cause. im leaning towards replacing the injectors that appears to make the most sense.

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 12:18 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page