PeachParts Mercedes ShopForum

PeachParts Mercedes ShopForum (http://www.peachparts.com/shopforum/)
-   Tech Help (http://www.peachparts.com/shopforum/tech-help/)
-   -   '84 300SD vacuum problems? (http://www.peachparts.com/shopforum/tech-help/4612-84-300sd-vacuum-problems.html)

Ward1685@aol.com 06-29-1999 08:31 PM

I have a 1984 300SD with 122K. Everything is great with two exceptions.

First, the air conditioner does not blow through the vents in the front of the
dash but rather through the defroster vents up by the windshield.

Second, occassionally while driving, the brake pedal becomes very difficult to
depress. This condition always goes away after a while. Also, when I park while
the brake is difficult to depress, the engine will not turn off immediately but
rather keeps running for about a minute before it goes off.

I would greatly appreciate suggestions on what is wrong. Also, is this something a novice can fix or is this an expensive repair?

Thanks in advance


------------------

Ward1685@aol.com

mbdoc 06-29-1999 09:12 PM

Sounds like the vacuum pump isn't working up to par. The fitting at the top of the pump that the large vacuum line(brake booster) bolts to is a check valve. Many times this valve breaks & then the pump can't perform properly. START THERE

MB STARS 06-29-1999 11:51 PM

Yes,M.B.DOC is right,I have seen vacuum pump
out of order cause by missing check valve,
replace vacuum pump that should fix your problem.
About your a/c venting problem I will start
form checking vacuum leak under dashboard.
a/c venting flap is operate by vacuum servo,
any one of then leak will cause just like your complain.
Good luck to you.


All times are GMT -4. The time now is 05:50 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website